Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-22-2004, 11:47 PM
jesse james jet
Guest
 
Posts: n/a
Unhappy 1985 TD /none starting

HELLO FELLOW BENZ LOVERS,

I AM IN A BIG JAM, MY 85TD WAS NOT SHUTING OFF,I REPLACED THE VACUM CONTROL ON THE REAR OF THE INJECTION PUMP,THE ENGINE STARTED IN WIDE OPEN THROTTLE, I PUSHED THE SHUTOFF CONTROL NOTHING HAPPENED, THE ENGINE WAS RUNNING HOT BLACK SMOKE COMING OUT LIKE A FRIEGHT TRAIN, I PANICKED AND PULLED THE RUBBER HOSE LOSE TO THE FUEL FILTER IT STOPED INSTANTLY, I FOUND PEICES OF MY TURBINE WHEEL BEHIND THE TAIL PIPE ON THE TO HOT TO PICK UP, I TOOK THE TURBO AN FOUND THAT THE REAR TURBINE BLADE HAD SHEARED OFF AN WENT THROUGH MY EXHAUST, I CHANGED THE OIL AN INSTALLED A NEW INJECTOR AFTER SETTING TO ENGINE 24BTC AN SETTING THE TIMING MARKS ON THE INJECTOR, I WANT TO GET IT STARTED BEFORE REPLACING THE TURBO, BUT IT HASN'T STARTED, DOES A NON WORKING TURBO PREVENT STARTING OR MAYBE THE VACUM LINES ARE NOT INSTALLED CORECTLY, IS THERE ANY HOPE FOR TIRED BENZ OWNER.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page