Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-03-2004, 06:17 PM
Registered User
 
Join Date: May 2004
Posts: 217
Question 300 SDL Have ignition switch proplem...

As I come to be more aquainted with my new hobby, the 300SDL, I'm discovering more faults that need attention. Some are small and some will require more effort.

The immediate issue is my ignition switch. After a recent installation of a replacement injection pump, and it did start eventually without any need to bleed the fuel supply system, thanks again for the in-put. I have discovered that when the key is turned all the way, it does not activate the starter solinoid. I have to jump the starter with a box-end wrench. All other functions of the ignition switch work properly.

Do I need a new ignition switch or is there something else on-line between the ignition switch and solinoid such as a relay that might be faulty?


Previous MB's: 1985 190E 186K sold it......1983 300D.......433K donated it.

Last edited by Sooty Taillight; 05-03-2004 at 06:23 PM.
Reply With Quote
  #2  
Old 05-03-2004, 06:36 PM
Registered User
 
Join Date: Nov 2001
Location: North Central Kentucky
Posts: 1,065
Neutral safety switch could be bad or out of adjustment. Try this:
Put emergency brake on max. Put both feet on regular brake pedal and push HARD. Now, turn key to start with one hand and move shifter around. Try starting in neutral and move stick slightly forward and back. See if engine trys to crank. If it does, turn key to OFF right away. Anything more than this will probably require a wiring diagram. Oh, and make sure no one is standing anywhere near the car when you do this test as the car may move.
Reply With Quote
  #3  
Old 05-03-2004, 07:26 PM
Registered User
 
Join Date: May 2004
Posts: 217
Reply

Thank You BobK....I forgot to mention that I have tried moving the shifter around just as you suggested but nothing!

A few years back, I had a similar problem with my 85 190E. The difference here is that the spring load into start engages as normal, on my 190E, as I remeber, the spring load let go just as I had attempted to start upon leaving a gas station. I ended up having to have it towed home. I installed a momentary push button switch under the dash instead of replacing the ignition switch. I may consider doing the same with this car as it seems like there may be the need for dealership intervention with special tools required!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page