Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz Performance Paddock

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-09-2016, 07:36 AM
Registered User
 
Join Date: May 2016
Location: Norway
Posts: 39
m104 turbo project

hello! just joined this forum!
And I'm new to the megasquirt, so i'm hoping for some help and some tips!
sorry for the bad english, don't use it so often...

I got a w124 stv that i'm building up right now.

Got a turbina tb70 from turbobandit with a exhaust manifold that looks awesome and a wesgate. dumpvalve,intercooler and the ms3x.
it all goes to the engine m104.990 that i was using the top part of the head from the m104 280, so i could run with the original 3 coils on plugs and the ecu that was on from original. just got a new headgasket and it has only 86000miles on it. it has the dubble valve springs, so it should be able to bare about 0.8bar witout coppergasket from turbobandit or machine the pistons i think is what i did read.
got the 717.450 dogleg getrag transmission that should hold for a while i guess.

So i just got the turbina and the ms3x hooked to the engine.
i planed to use the original temp sensors and the cam and crank sensors that is on the m104 just to get it started then upgrade later if that is posible?
So I'm planning on going with Sequential injection and have ordered the quadspark so i can go with the original 3 coils on plugs with the wasted spark.
Also ordered a wideband sensor.

As it is now, i'm hoping to get the quadspark and the wideband this week.

So if i got this right the m104 throttle body only got a on and off switch, not a sensor. so i can only use the map sensor at start?

I'm planning to go with the stock fuel pump and the stock injectors just to start with. if i'm right they sould hold for a 0,4 - 0,5 bar on the turbo?
i read about the injectors only beeing 19lbs.

And then there is the ignition degrees and map and the fuel maps, anyone that got any basic maps and stuff for the m104 or something like that to get it started?

sorry for all the probably dump questions, but i have searching forums for the past 2 weeks for mostly everything while building up this build, so much of my questions are probably out there somewhere.
but I greatly appreciate everyone who takes the time to help me on this.
Cant wait to get it started!!

Reply With Quote
  #2  
Old 05-09-2016, 07:37 AM
Registered User
 
Join Date: May 2016
Location: Norway
Posts: 39
Imgur: The most awesome images on the Internet
Reply With Quote
  #3  
Old 05-14-2016, 07:03 PM
Registered User
 
Join Date: Feb 2007
Location: los angeles
Posts: 590
How can I purchase the exhaust manifold?only Turbo bandit?
Reply With Quote
  #4  
Old 05-15-2016, 05:12 AM
Knappy Drag Racer
 
Join Date: Jun 2008
Posts: 1,725
Hey nulu, you didn't say anything about adding a turbo to that C36 engine..... What's up with dat?
__________________
89 300E "Benzer1" 15.924 Uncorrected
93 400E "Benzer3" 14.200 U.C.
95 E420 "Benzer4"
92 300E "Benzer5" 16.299 U.C. Future turbo CNG
87 300D "Benzer7"
87 300D "Benzer8"
87 300D "Benzer9"
87 300D/70 AMC Javelin "Sidewinder-Benzer"
87 300TD "Benzer11"
06 E320 CDI "Benzer12"
05 E320 CDI "Benzer12A"
71 AMC Javelin AMX 401 "Sidewinder"
74 AMC Hornet 401 "C.K.10" 13.63 U.C.
74 Bricklin SV1 "Presto" AMC 360 pwrd.
Reply With Quote
  #5  
Old 05-15-2016, 11:58 AM
Registered User
 
Join Date: Jul 2013
Posts: 87
My friend has a w201 sportlines that he swapped in a m104 into. He is running megasquirt 2 with the stock 3 ignition coils. He has a regular non-dogleg 5 speed transmission. He's smoked several clutches, and blown up the transmission a couple times under N/A power.

He has a turbo bandit manifold and a hx40w turbo for the car, not installed yet. He's not confident a Mercedes transmission will hold the power.

He's a bit of an Internet troll, and not to helpful to ask questions from. But his build thread is on 190rev. His screen name is 202brabus.
Reply With Quote
  #6  
Old 05-15-2016, 01:30 PM
oldsinner111's Avatar
love all animals
 
Join Date: Nov 2008
Location: bristol,tn
Posts: 5,442
On turbo bandits site yesterday I read the 722.6xx is good for 600hp,they say its stronger than a manual trans.They have some cheap basic kits,but you would need extras.
__________________
usaf vet,dumb ass,repukes love the wealthy,dems use to protect working citizens.Both sides are parasites
Reply With Quote
  #7  
Old 05-16-2016, 05:53 PM
Registered User
 
Join Date: Feb 2007
Location: los angeles
Posts: 590
Quote:
Originally Posted by 400Eric View Post
Hey nulu, you didn't say anything about adding a turbo to that C36 engine..... What's up with dat?
the turbo bandit exhaust looks very nice , about $800.00 , but how can i purchase it there in sweden?, just exercising my options, i may keep all the
c 36 internals except pistons and use my brand new mercedes 104 block original bore, that way i wont blow headgaskets, im thinking of turbo , and 722.6 trans .500-600 horse?
Reply With Quote
  #8  
Old 05-16-2016, 06:00 PM
Registered User
 
Join Date: Feb 2007
Location: los angeles
Posts: 590
ive got 4 engines a 2.8 block , original 104 block in 94 wagon , brand new in the box 104 engine bare,(just block), a complete c 36 104 from 95 c36 with ecu ,i can go build, and ported exhaust etc, or leave everthing and go turbo with any combo , im investigating stand alone ecu 's, im undecided ,if i go turbo i may as well go big, ive already bought another differential in case i blow up my 94 wagon diff., this will be a sleeper wagon build

Last edited by nulu; 05-19-2016 at 10:22 AM.
Reply With Quote
  #9  
Old 05-17-2016, 01:21 PM
Registered User
 
Join Date: Aug 2005
Location: Napa Valley
Posts: 349
Quote:
Originally Posted by oldsinner111 View Post
On turbo bandits site yesterday I read the 722.6xx is good for 600hp,they say its stronger than a manual trans.They have some cheap basic kits,but you would need extras.
Whoever wrote the Wikipedia entry for the 722.6 claims it's good for 796 ft/lbs. of torque.
https://en.wikipedia.org/wiki/Mercedes-Benz_5G-Tronic_transmission
Reply With Quote
  #10  
Old 05-17-2016, 01:40 PM
Registered User
 
Join Date: Oct 2004
Posts: 3,225
Not all will but some did come from the factory built that tough. It's not too hard to build one up either. I've seen aftermarket suppliers offer a one year warranty up to 1000 ft lbs.
Reply With Quote
  #11  
Old 05-19-2016, 01:36 PM
Registered User
 
Join Date: May 2016
Location: Norway
Posts: 39
finaly got the quadspark! got it wired up, tried cranking the engine abit, but wont start.
probably need to go over the wiring and maps.
Reply With Quote
  #12  
Old 05-25-2016, 07:59 AM
ToxicSwordFish's Avatar
Registered User
 
Join Date: May 2016
Posts: 20
for this build did you bore out the block? Also what are you doing for pistons, stock or aftermarket? Im doing something similar but im having my block bored and am having a tough time finding pistons that will work.
thanks man
Reply With Quote
  #13  
Old 05-25-2016, 03:13 PM
Registered User
 
Join Date: May 2016
Location: Norway
Posts: 39
got the crank sensor wired up the right way now i think. and got the ignition timing right to i think.
But suddenly all the sensors stopped working. tested all sensors, cam sensors and the ground for the sensors. everything check out right.
anyone experienced something like this? no gauges on tunerstudio reading anything.

Planning on thicker headgasket only for starting. the pistons and the block is suposed to handle alot, atleast that what the guys at turbobandit says.
Reply With Quote
  #14  
Old 05-28-2016, 04:48 PM
Registered User
 
Join Date: May 2016
Location: Norway
Posts: 39
Now i got the sensors right again. Got rpm signal while cranking, jumping abit up and down. Got spark and fuel, so the car is almoust starting now! Going to search for some maps and stuff tomorrow! Hopefully it starts!

Last edited by fiksm104; 05-28-2016 at 08:23 PM.
Reply With Quote
  #15  
Old 06-05-2016, 03:13 PM
Registered User
 
Join Date: May 2016
Location: Norway
Posts: 39
The car is starting! But its shooting alot, and it looks like the rpm goes on and off. While the car is running the rpm drops to 0 and then up to about 2000 then off to 0 and so on.
Could it be the trim pots for the vr sensor that makes that happend?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page