Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz Performance Paddock

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-08-2003, 08:26 PM
Registered User
 
Join Date: Jan 2003
Location: Encino, CA
Posts: 275
C280 Cluster issues.

I just bought a 95 c280 for my wife and I noticed the cluster is not working 100%. The RPM gauge, fuel gauge and the temp gauge are all not working. The speedometer and odometer are working fine and so are all the lights. Anyone have any idea where I should start looking? Another thing is the car runs perfect when cold, strong smooth and full of power but when it warms up it starts running a little rough, as if it were missing. Any suggestions? I should add that the car has all service records and appears to be in near perfect condition. I thank you all in advance.

__________________
94 E500 Sport
SOLD:
2002 BMW M3 Coupe 6 Speed.
SOLD:
92 500E Black Pearl, Black.
18" 2 Piece AMG
ASR Defeat
Performance Chip
Crossed Drilled Rotors.
Reply With Quote
  #2  
Old 02-09-2003, 02:17 PM
Registered User
 
Join Date: Jan 2003
Location: Encino, CA
Posts: 275
C'mon I know someone out there knows something about this problem of mine.
__________________
94 E500 Sport
SOLD:
2002 BMW M3 Coupe 6 Speed.
SOLD:
92 500E Black Pearl, Black.
18" 2 Piece AMG
ASR Defeat
Performance Chip
Crossed Drilled Rotors.
Reply With Quote
  #3  
Old 02-09-2003, 04:36 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
If I were given this car to diagnose, I would check the inputs to the cluster for fuel level, RPM, and engine temp sensor. I would probably start by checking "actual values" with the hand Held Tester or SDS, and if nothing for these readings were showing, I'd check it at the cluster connectors just to be sure.
Ultimately it sounds like most likely you need a new instrument cluster. You may find someone who claims to repair them, if so it would be worth a shot.
On the cold driveability issue, possibly it just needs spark plugs and fuel & air filters.

Gilly

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page