Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-12-2008, 07:42 PM
Registered User
 
Join Date: May 2007
Location: LIVINGSTON, TENNESSEE
Posts: 30
Question heat issues...maybe thermostat??

What temperature should the temp gauge show on an 89 560 SL??
Mine registers about 80 and I do not have enough heat...do I need a new thermostat??

Thanks

jtu
Reply With Quote
  #2  
Old 11-12-2008, 09:34 PM
126 Guy
 
Join Date: Sep 2005
Location: Queens, NY
Posts: 523
try flushing the cooling system and putting new coolant. if there is still little or no heat after that, check for any coolant leaks or you might have a restriction somewhere in the heater core. you might just have air in the system. use the search thread here relating to this issue, you will find alot of tips
__________________
2001 E55

2001 E320 Sedan

2001 Subaru Legacy

2006 SLK280

2016 Subaru Outback 3.6
Reply With Quote
  #3  
Old 11-12-2008, 09:52 PM
Super Moderator
 
Join Date: Apr 2000
Location: Falls Church, VA
Posts: 5,316
You could also have a bad monovalve, not allowing hot coolant into the heater core. Other possible components are the control (pushbutton) unit and the temperature control relay.

Lots of posts on these components and their problems.
__________________
Chuck Taylor
Falls Church VA
'66 200, '66 230SL, '96 SL500. Sold: '81 380SL, '86 300E, '72 250C, '95 C220, 3 '84 280SL's '90 420SEL, '72 280SE, '73 280C, '78 280SE, '70 280SL, '77 450SL, '85 380SL, '87 560SL, '85 380SL, '72 350SL, '96 S500 Coupe
Reply With Quote
  #4  
Old 11-13-2008, 02:59 AM
coleyjf's Avatar
Old dog - new tricks
 
Join Date: May 2005
Location: East Midlands of the UK
Posts: 264
Quote:
Originally Posted by jtupton View Post
What temperature should the temp gauge show on an 89 560 SL??
Mine registers about 80 and I do not have enough heat...do I need a new thermostat??

Thanks

jtu
To respond to your original question - 80deg is about the right temperature so It doesn't sound like a stat problem - more like a heater issue as stated above.

Cheers

Jim
__________________
Keep your Motor runnin'

Jim's '88 300SL
Reply With Quote
  #5  
Old 11-13-2008, 09:03 AM
Registered User
 
Join Date: May 2006
Location: Bradenton, FL
Posts: 286
Quote:
Originally Posted by jtupton View Post
What temperature should the temp gauge show on an 89 560 SL??
Mine registers about 80 and I do not have enough heat...do I need a new thermostat??

Thanks

jtu
I agree it's probably not the thermostat...what happens when you turn the temp wheel so it 'clicks' into the MAX setting?

Bob
__________________
Bob Jones
Bradenton, FL
'87 560SL-Sold
'99 SL500 For Now
Reply With Quote
  #6  
Old 11-15-2008, 08:22 AM
Registered User
 
Join Date: May 2007
Location: LIVINGSTON, TENNESSEE
Posts: 30
heat issue.........

When the temp wheel is clicked to the Max position, the temperature will slowly rise after driving for 20+ minutes, but never gets warm enough to need to turn the heat down.

Thanks for all the responses...I will flush the system and add new coolant.

jtu
Reply With Quote
  #7  
Old 11-16-2008, 05:16 PM
Registered User
 
Join Date: Oct 2007
Location: Greater Metropolitan Beaverdam VA
Posts: 1,866
monovalve

80 deg C is right as others have stated. Recommend you open your monovalve and check the state of the diaphragm. Easy and fast to do. If diaphragm is ruptured (I'll stake Strife's reputation that it is), get an inexpensive repair kit ($45 ?) from Fastlane Phil and fix your problem.

Let us know how you do.

BTW, I start getting heat almost as soon as the car starts moving and with the control set in the center of the white section get all the heat I want. Check that monovalve before draining, flushing and refilling. You will lose no coolant when you open the monovalve.

Last edited by rocky raccoon; 11-16-2008 at 05:21 PM. Reason: add information.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page