Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-26-2009, 10:14 PM
Registered User
 
Join Date: Feb 2009
Posts: 5
92 Sl500 wacky gauges

I have a 92 SL500, and the only gauge that works is the temp ??
no speedo, no tach nothing
any ideas??
also not sure if related but the electric release for the hard top quit.

any ideas would be greatly appreciated
Reply With Quote
  #2  
Old 02-26-2009, 10:34 PM
Registered User
 
Join Date: Mar 2003
Location: Milwaukee Wisconsin
Posts: 1,150
Your two problems are probably not related, but both are quite common in the early 129 chassis. Much has been written about both issues in the past in this forum. Use the forum search tool to do some research. Use "cluster" for the guage problem and "soft top controller" for the hard top release problem. After reading through the copious information, if you don't find an answer, add to your post with more specific questions. We've had a lot of experience in the group on these matters. Welcome to the forum.
__________________
Resistance is Futile.
Reply With Quote
  #3  
Old 02-28-2009, 05:11 AM
Registered User
 
Join Date: Jan 2009
Posts: 17
other people also have reported power top problems related to the instrument cluster gremlins... temp gauge is on its own separate circuit... its likely that the cluster needs replaced or repaired (eBay), but to be certain, there are a few wires that plug into the back of the cluster that need to be tested... here's what's not posted nowhere : unplug connector 2 and look for 12v on pins 11 and 12; then unplug connector 1 and look for 12v on pins 10 and 1, then on pins 10 and 5... if you measure around 12v on all three of those combinations, then your cluster is the problem... grounds are also good to check with a light, but you gotta go on alldata for diagrams of where they are...
__________________
1991 MB SL300, 1994 Sub 4x4 6.5L TD, 1986 K30 4x4 6.2L, other toys
____________________________
"Back up four feet and floor it..."
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page