Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-20-2004, 05:43 PM
Registered User
 
Join Date: May 2002
Location: NH
Posts: 23
engine running rough and stalls when hot at idle

My 88 560sl stalls and idles rough after the engine gets up to temperature especially when coming off the highway. My mechanic replaces the o2 sensor, coolant sensor, and fuel pump but it still. Any thoughts! I'm at my wits end.

tim

Reply With Quote
  #2  
Old 05-21-2004, 11:50 AM
Registered User
 
Join Date: Sep 2001
Location: Austin, TX
Posts: 563
Check the solder joints on the fuel pump relay.

Oh, and find another mechanic. You don't want one that is just going to throw parts at a problem.

__________________
Mike Heath
1988 560SL Black/Palomino
1988 300SEL Black Pearl/Burgandy
1984 500SEC Anthracite Grey/Palomino
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page