Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > ML, GL, G-Wagen, R-Class, Unimog, Sprinter

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-19-2014, 02:38 PM
tyl604's Avatar
Registered User
 
Join Date: Feb 2008
Location: Atlanta, GA
Posts: 3,211
WTB - Radio for 2002 ML320

Guys - bought a 2002 ML320 from Tyler (good guy) and need to replace the radio. Anyone got a good one?
Reply With Quote
  #2  
Old 08-19-2014, 08:09 PM
tyl604's Avatar
Registered User
 
Join Date: Feb 2008
Location: Atlanta, GA
Posts: 3,211
Bump
Reply With Quote
  #3  
Old 08-29-2014, 01:11 AM
Jim in Phoenix
 
Join Date: Aug 2004
Location: Phoenix, AZ
Posts: 149
Quote:
Originally Posted by tyl604 View Post
Guys - bought a 2002 ML320 from Tyler (good guy) and need to replace the radio. Anyone got a good one?
Are you sure it's bad?--you may just need the anti-theft 4 digit code, available from the dealer if you can prove ownership. Also check BOTH fuses!

I have a nice one out of my 98 ML320, but may not interchange. photo available. $75

Jim in Phoenix
Reply With Quote
  #4  
Old 08-29-2014, 12:16 PM
ILUVMILS's Avatar
Senior Member
 
Join Date: Sep 2002
Posts: 2,587
Is the display screen damaged or are you having an audio issue?
Reply With Quote
  #5  
Old 08-30-2014, 12:31 AM
Registered User
 
Join Date: Feb 2007
Location: SD California
Posts: 153
ML Radio

This type of radio?



2005 C230K sdn
2002 C230k coupe
2002 C240
1998 ML320
1996 C36
1998 528i
Attached Thumbnails
WTB - Radio for 2002 ML320-dsc_0879.jpg  
Reply With Quote
  #6  
Old 09-02-2014, 10:55 PM
tyl604's Avatar
Registered User
 
Join Date: Feb 2008
Location: Atlanta, GA
Posts: 3,211
Sorry guys, been on vacation. Yes, at first glance it looks like the radio in the pic. I bought the ML from Tyler and the radio had been working while he drove it around the city. But when my daughter picked it up, it worked for an hour or so and then no sound. Tyler was willing to have it fixed but my daughter was in too much a hurry to get back to Auburn. So I am trying to figure out what to do. Bought some keys so I can pull it and get the model number of the radio. And I wonder if someone in Auburn can solder something or replace something - but right now I am wondering about just sliding in another radio.

What is the consensus of opinion out there? I think it is not a fuse since the screen lights up and works fine - just no sound - CD player works fine. Tyler's radio man looked at the antenna connection which is a likely culprit but that was not it. Not sure what to do.

Advice appreciated.

By the way, Tyler is first class; buy a car from him if you can.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page