Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > ML, GL, G-Wagen, R-Class, Unimog, Sprinter

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-13-2016, 09:02 PM
Registered User
 
Join Date: May 2015
Posts: 22
'98 ML320 with a part that continues to run after turning off ignition

Our '98 ML320 runs fine, but when we turn it off lately there has been a component that fails to shut off. Pics are attached of the part that keeps making a loud humming noise/vibration, which is under the hood on the driver's side below the windshield wiper fluid reservoir.

It will drain the battery, unless we unplug the battery cable after parking. It doesn't ALWAYS happen every time we drive, but it is very noticeable when it doesn't automatically shut off. We think it may be connected somehow to the ac/heater fan control unit. There seems to be a short and our blower isn't moving any air when we turn on the fan control.

Can you please tell me what this part is?


Thank you for your feedback
Attached Thumbnails
'98 ML320 with a part that continues to run after turning off ignition-car-part1.jpg   '98 ML320 with a part that continues to run after turning off ignition-0511161255.jpg  
Reply With Quote
  #2  
Old 05-13-2016, 10:24 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,166
That's the ABS unit , the relay that runs the pump is probably sticks or the ABS controller is failing.
Reply With Quote
  #3  
Old 05-16-2016, 07:49 AM
Registered User
 
Join Date: May 2015
Posts: 14
Thank you, SL320! The ABS light has been on for 2 years now.

There has also been some sort of electrical short, is it possible they are related?
Reply With Quote
  #4  
Old 05-16-2016, 05:40 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,166
I'd need to see a wiring diagram to determine where the ABS motor relay is. Sometimes MB places a bunch of relays in one module / box so there might be some connection but that is a guess until research is done.
Reply With Quote
  #5  
Old 05-26-2016, 12:11 AM
Registered User
 
Join Date: May 2015
Posts: 14
I'm going to have someone check the ABS relay tomorrow.
Reply With Quote
  #6  
Old 05-27-2016, 04:43 PM
Registered User
 
Join Date: May 2015
Posts: 22
Is there a wiring diagram for the ABS relay?
Reply With Quote
  #7  
Old 06-29-2016, 09:28 PM
Registered User
 
Join Date: Jul 2006
Posts: 16
I hope this link from benzworld works. You should be able to pull the ABS relay from the fuse panel stopping the motor from running on. You may just have to replace the relay, but it may be as serious as a short or a loose
ground. In any case DO NOT DRIVE with this relay removed, I don't know if it poses a safety risk or not.

Last edited by Diamlerman; 06-29-2016 at 09:54 PM. Reason: url not working
Reply With Quote
  #8  
Old 06-29-2016, 10:25 PM
Registered User
 
Join Date: Jul 2006
Posts: 16
'98 ML320 with a part that continues to run after turning off ignition-fuse%2520layout%5B1%5D.jpg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page