Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > ML, GL, G-Wagen, R-Class, Unimog, Sprinter

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-22-2018, 01:23 PM
tyl604's Avatar
Registered User
 
Join Date: Feb 2008
Location: Atlanta, GA
Posts: 3,211
2002 ML320 hard to get into Park

Daughter's vehicle. Sometimes the shifter will not go into Park. And usually it just slides in fine.

What could be the problem? Bushings on the shifter? Something trying to lock it out for some reason?

Well, I just went back and saw a thread I started in May 2017 with same problem - but still not resolved.

Last edited by tyl604; 10-23-2018 at 05:44 PM.
Reply With Quote
  #2  
Old 10-22-2018, 07:11 PM
tyl604's Avatar
Registered User
 
Join Date: Feb 2008
Location: Atlanta, GA
Posts: 3,211
New problem. When I filled it up with gas, the gauge only read half full; by the time I had driven two miles, it had fallen to 3/4 empty even though it was full. Then shortly thereafter the tach stopped working.

Could this be a fuse problem?

Any idea?

Thx
Reply With Quote
  #3  
Old 10-23-2018, 05:45 PM
tyl604's Avatar
Registered User
 
Join Date: Feb 2008
Location: Atlanta, GA
Posts: 3,211
Bump. Need some help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page