Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > ML, GL, G-Wagen, R-Class, Unimog, Sprinter

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-23-2018, 08:57 PM
Registered User
 
Join Date: Jan 2017
Location: Leesburg, VA
Posts: 120
Code 150200 Upper limits value components HFM SFi has been exceeded

I have ML 320 Blutec with OM 642 diesel engine.

I have this code per my code reader. I can't even clear this code, it goes away and come back right the way on code reader even if I will not turn a car on. If restarted a car Check Engine will be illuminate again. I have normal driving, no loss power and all work as is. I replaced about month ago EGR valve (what is pain.)
Used start system to adopt a new EGR. Everything was fine until few days back.
its hard fault and no solution.I tried disconnected plugs from MAF and boost sensor and nothing help - Upper limits value components HFM SFi has been exceeded is still there .


[
__________________
91' MB 350 SDL, with 961 engine and #14 valve head
09' ML320 Bluetec
Reply With Quote
  #2  
Old 10-23-2018, 09:32 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,179
HFM_SFI is a term generally used to describe the 1992 - 96 ish gas engine injection system in it's entirety. I think there is a problem with the scan tools description and it should state MAF / air flow meter.

Look at the live data and see if the MAF produces believable voltages. Generally, a MAF will output 0.5 V with no air flow and 4.5 V at max but your car might be different. If the computer sees < 0.5 or > 4.5, it triggers a voltage too low / lower limit or voltage too high / upper limit code.

It would be a good idea to measure actual voltage output of the MAF as on other cars, I've had a component failure and the ECU generate a substitute value that the scan tool picks up.
Reply With Quote
  #3  
Old 10-29-2018, 09:26 AM
Registered User
 
Join Date: Jan 2017
Location: Leesburg, VA
Posts: 120
I replaced my MAF's with older ones, as I replaced Y pipe. So it's not MAf's. It might need it reprogram all system ? Any MB mechanics here? Need a help. I'm in Sterling area VA. I'm thinking to take it to dealership but i'm afraid they will start swapping part around and no fix near future.
__________________
91' MB 350 SDL, with 961 engine and #14 valve head
09' ML320 Bluetec
Reply With Quote
  #4  
Old 10-29-2018, 11:32 AM
Registered User
 
Join Date: Jan 2012
Posts: 7,179
Did you read my post 2 at all?
Reply With Quote
  #5  
Old 10-30-2018, 08:30 PM
Registered User
 
Join Date: Jan 2017
Location: Leesburg, VA
Posts: 120
yes I need to get Star diagnostic to check.
__________________
91' MB 350 SDL, with 961 engine and #14 valve head
09' ML320 Bluetec
Reply With Quote
  #6  
Old 10-30-2018, 09:20 PM
Registered User
 
Join Date: Oct 2004
Posts: 3,229
Air mass faults indicate EGR flow problems on this platform.

I'd
#1 remove and clean the EGR elbow on the front of the engine.
#2 reset air filter and air mass adaptations (SDS required)
#3 flash update CDI with the latest software (SDS and Xentry access required)
__________________
90 300TE 4-M

Turbo 103, T3/T04E 50 trim
T04B cover .60 AR
Stage 3 turbine .63 AR
A2W I/C, 40 LB/HR
MS2E, 60-2 Direct Coil Control
3" Exh, AEM W/B O2
Underdrive Alt. and P/S Pulleys,
Vented Rear Discs, .034 Booster.
3.07 diffs 1st Gear Start

90 300CE 104.980
Milled & ported head, 10.3:1 compression
197 intake cam w/20 advancer
4 ignition advance
PCS TCM2000, built 722.6
600W networked suction fan
Sportline sway bars
V8 rear subframe, Quaife ATB 3.06 diff
Reply With Quote
  #7  
Old 11-06-2018, 05:54 PM
Registered User
 
Join Date: Jan 2017
Location: Leesburg, VA
Posts: 120
i got this fix. My tech resent all adoption control for engine, and be able to clear a code. So I drove around 1,000 miles over weekend and so far no code.
it might be need a new software from MB.
__________________
91' MB 350 SDL, with 961 engine and #14 valve head
09' ML320 Bluetec
Reply With Quote
  #8  
Old 11-27-2018, 08:02 PM
Registered User
 
Join Date: Jan 2017
Location: Leesburg, VA
Posts: 120
well it came back after 300-400 miles. It's definitely a swirls flaps on intake or engine ECU per dealer. They told me they can do swirl motor and clean intake for couple thousand dollars and than try re program ECU but no guarantee.
So I was sad and mad, than stop by Jeep dealer as same motor was used on some Jeep. But instead fixing I got trade deal and traded for Jeep GC diesel with warranty.
__________________
91' MB 350 SDL, with 961 engine and #14 valve head
09' ML320 Bluetec
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page