Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > SL Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-17-2004, 02:47 AM
Registered User
 
Join Date: Apr 2003
Posts: 12
battery replacement - 3rd brake light

While checking the inoperative 3rd brakelight on my 96 SL320, I discharged the battery (2 brake lites and AC fan were on), and lost the window sync. among other things. I checked with hygrmtr and charged the batt, but I am only buying time I know.

After charging overnite, re-established window sync, and remote lock/alarm, and the car cranks fine, but the TOP up/down light, and the Rollbar indicator lights are on. Does anyone know what steps are necessary to reset these red lites?

I've searched the site, found reference it Interstate MTP93 battery as direct replacement, I can't complain about the MB battery life(8yrs) and have no idea of the cost, any recomendations on aftermarket batteries?

Also read on the site of battery's being incorrectly connected and damaging electrical/computer componets, am I correct in my assumption that the standard battery procedure, connect positive lead first, and then the ground lead, is correct?

BTW, the 3rd brake light looks to have a broken hot wire, (gnd is good) and I will check for power on the other side of the trunk-hinge bend where it goes into a heavy plastic sleeve and harness.

TIA for your input,
MikeK
Stanley, NC
K1200RS
Reply With Quote
  #2  
Old 05-18-2004, 12:55 AM
Registered User
 
Join Date: May 2001
Location: Las Vegas, Atlanta
Posts: 669
Your lights are on because codes are set in the soft top controller, and I believe the only way to reset them is to run diagnostics. For '96 and newer SLs, this requires the M-B Hand-Held Tester or a diagnostic tool with similar capabilities. Very expensive. You'll probably have to go to the dealer or a well-equiped shop. It will take them about 10 minutes tops. The only other possibility -- extremely remote I believe -- is that they will reset themselves over time. Might be worth posting in the Tech Help forum to solicit a 2nd opinion.

Regarding batteries, I personally have no preference for one brand over any other.
Reply With Quote
  #3  
Old 06-01-2004, 01:19 PM
Registered User
 
Join Date: Apr 2003
Posts: 12
Problems resolved:
1) 3rd brake lite had broken +12V wire in the harness, exactly where the rubber strain relief sleeve ends and enters the guide along the trunk hinge. Poor design IMHO, bending wired nearly double with every opening and shutting of trunk, but it looks nice before it breaks. I expect they ALL will break there sooner or later, ya'll should put it in the FAQs

2) Advance Auto parts sells and an exact replacement battery. Rated higher amps then the OEM Varta/Mercedes batt., same dimensions as original, with same plastic (+) term. cover.
Called their "International Titanium" battery, group 49-1 and cost $70.

3) Bobterry's advise was spot on(thanks Bob) , Rollbar and top indicator lites being on had to be re-set with MB computer at independent MB shop (MBV Auto in Charlotte, good folks BTW). In chatting with mechanic, this is SOP any time a battery is discharged completely or disconnected, their charge to re-set lights/computer is $80.

Add the two charges and that about equals the price of a MB dealer battery less install labor and resetting computer.
MBV tech's advise on removing/installing batteries is same as all other manufacturers, remove ground cable FIRST to disconnect, install ground cable LAST to connect, don't jiggle it on/off/on/off.

Next time I cross this bridge there will be an aux 12v batt firmly connected in parallel to vehicle batt to retain all computer memory before pulling the dead batt.
Lucas electrics on my TR-4 are much easier to deal with!

Mike Kelly
Stanley, NC
K1200RS
Reply With Quote
  #4  
Old 06-01-2004, 08:33 PM
ddb ddb is offline
Registered User
 
Join Date: Feb 2003
Posts: 47
MBV Auto

Mike,

Where is MBV Auto located? I'm in CLT and am not familiar with this shop. Have they serviced your SL previously? I currently have a 124 and plan on buying a 129 this summer.

Thanks,

Derek
Reply With Quote
  #5  
Old 06-02-2004, 12:56 AM
Registered User
 
Join Date: Apr 2003
Posts: 12
Derek,
about 1/8 mile N of intersection Tyvola Rd and Old Pineville Rd, just off South Blvd.
They have shown excellent quality and fair pricing the times they have performed service on our SL.
Wife wants a to buy a Z4 Bimmer, let me know if you are in the market for a pristine 96 SL320.

Mike K
Stanley, NC
K1200RS
Reply With Quote
  #6  
Old 06-02-2004, 06:50 PM
ddb ddb is offline
Registered User
 
Join Date: Feb 2003
Posts: 47
Mike,

Thanks for the information. I have my heart set on a SL500. What are your impressions of the SL? Just out of curiosity, what color is your car?

Have you and your wife driven a Z4? What do you think?

Good Luck.

Derek
Reply With Quote
  #7  
Old 06-03-2004, 12:11 AM
Registered User
 
Join Date: Apr 2003
Posts: 12
SL is a 'really cool' car.
I have a 1964 Triumph TR4. When I drive it, people grin and wave. When I drive the SL, people don't grin and wave, they just look like they WISH they had one.
Car is incredible in every way, and a joy as a daily driver. Our biggest concern is putting too many miles on it, thus making it hard to sell for top dollar, and IMHO, the car is too technical to keep forever and enjoy like my TR4.
Car is white, black softtop goes down regularly this time of year.
Have driven Z3's, no Z4. I just want a silver Bimmer to go with my silver Beemer K1200RS motorcycle.

MikeK
Reply With Quote
  #8  
Old 06-11-2004, 12:23 AM
Boudreaux's Avatar
Mein Name ist Dieter.
 
Join Date: Sep 2003
Location: Pearland, TX
Posts: 174
BTW is there a certain way to disconnect/connect a new battery on an R129? I've read that if it is not done correctly that modules get blown and light codes pop up like a Christmas tree. Can anybody clarify this issue with the battery?
__________________
'94 SL500 Tourmaline Green, 120K miles as of February 27, 2005.

http://home.earthlink.net/~boudreaux...ictures/17.jpg
Updated photo September 2004
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page