Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-28-2004, 03:13 AM
Registered User
 
Join Date: Jul 2004
Location: mesa, az
Posts: 4
c-280 dash lights and gauges

would anybody know when i'm driving on the highway, my abs light, e-brake light, check engine light, comes on and my spedo drops to zero for a quick second. i don't have any loss of power or speed, but just recently in the morning when first starts up it has a hard time or after a long sit in the day time. i put a used only 50k mass air flow sensor on and new plugs after this started. i have a 96 c-280 with about 128k miles on it. it was a california car and i have just moved to arizona. if anyone can help please let me know.
thanx
tatalovich
Reply With Quote
  #2  
Old 07-28-2004, 05:26 AM
Registered User
 
Join Date: Jul 2004
Location: anytown, USA
Posts: 95
Find and check all of the negative battery post to ground/earth body connections...

Just trying to help thanks...
Reply With Quote
  #3  
Old 07-28-2004, 07:45 PM
Registered User
 
Join Date: Jul 2004
Location: mesa, az
Posts: 4
thanks i'll try that.


thank you
tatalovich
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page