Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-04-2000, 03:23 PM
jpowell490
Guest
 
Posts: n/a
Now that the magnet is replaced, when I bolt the water pump pulley back on it won't turn?? I have tried to beat that metal piece that the magnet bolts to further back on the water pump with no avail. Please anyone give me an answer. Thanks,
Reply With Quote
  #2  
Old 11-04-2000, 11:20 PM
metricman
Guest
 
Posts: n/a
You were given the wrong water pump. Two to choose from. One with that bracket and one without. You shouldn't have to pound anything.....

------------------
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Final chapter for 190E clutch saga (I hope) Greg in Oz Tech Help 8 12-13-2012 01:10 PM
300SDL revitalized clutch fan sixto Diesel Discussion 33 09-05-2005 10:23 PM
replaced fan clutch - is new clutch defective? janko Tech Help 13 07-08-2005 02:05 PM
Fan clutch - M104 on M119 anyone done it? moruzzi Tech Help 4 05-18-2004 07:04 PM
'95 E320 operating temperature NikoE320 Tech Help 47 09-23-2003 04:05 AM



All times are GMT -4. The time now is 06:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page