Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-05-2000, 05:26 AM
Oliverp's Avatar
Registered User
Join Date: Aug 2000
Location: Toronto, Canada
Posts: 436
I originally took it to a main dealer who charged me loads of money and didn't do much other than dirty the car.
I have now taken it to a tech that used to work with all the main dealers who seems to know what he's doing and seems really honest and genuine.
Hopefully I will now start to save money, and get good service!

Thanks for all the replies, it's nice to know i'm not on my own with all these problems!

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Restoring an AMG Hammer Wagon, my story Part 1 Hammer Wagon Performance Paddock 19 09-06-2011 09:24 PM
FS 79' 280CE- Nice car yorktown5 Mercedes Cars For Sale 1 09-08-2004 12:09 PM
What tools to bring to pickup my 280SEL 4.5? Kurt Smith Vintage Mercedes 24 01-19-2004 03:25 PM
New car owners embarassed by vintage cars? 300SDog Vintage Mercedes 23 02-11-2003 10:47 PM
intermittent no starting 420SEL david74mr Tech Help 19 11-12-2002 10:23 AM

All times are GMT -4. The time now is 04:38 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page