Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-11-2000, 12:35 PM
Posts: n/a
Any suggestions Is it in the wiper motor or turn signal arm, or is there a relay?
Any help would be appreciated
Reply With Quote
Old 11-11-2000, 07:53 PM
Registered User
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
I'll bet it's the switch. The motor get the current to run thru the switch, relay and delay element. If the motor is running when you cycle the wash function, then the probability is that some part of the control system is not working properly.

Jeff Lawrence
1989 300e
2000 Dodge Grand Caravan SE

[This message has been edited by jeffsr (edited 11-12-2000).]
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W126 window went down but won't go up! jp233 Tech Help 20 01-09-2005 01:08 PM
114 Coupe Window Problems ctaylor738 Vintage Mercedes 5 08-01-2004 12:59 PM
window stopped working, motor is fine adiel Diesel Discussion 10 03-10-2004 07:58 PM
116 Window Motor Swap..... 300SDog Vintage Mercedes 6 08-17-2003 07:05 PM
Future 2001 CL500 owner! lurker Featured Cars 10 12-29-2002 09:12 AM

All times are GMT -4. The time now is 01:51 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page