Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-12-2000, 05:53 AM
Registered User
 
Join Date: May 1999
Location: Calgary, Alberta, Canada
Posts: 190
I have an 1988 300E that has been idling high a lot of the time. If the car is in neutral or park it idles at about 1500rpms, but when it is in gear it idles at about 750-800rpms. Sometimes the idle while fluctuate between 800-1500-800 and so on. Any idea what may cause this?
Reply With Quote
  #2  
Old 11-12-2000, 06:41 PM
Registered User
 
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
check overvoltage relay. had similar problem before, bought updated OVR with red top and 2 fuses.
Reply With Quote
  #3  
Old 11-12-2000, 08:28 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
There are many reasons that this could happen. One could be a faulty sensor or sensors. Others could be air leaks. If the problem persists, you should have it checked by a professional.

------------------
Benzmac:
Donnie Drummonds
300E
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
OWNER OF MB AUTOWERKS .COM
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
300E fluctuating idle mike690003 Tech Help 9 10-20-2003 10:56 AM
FS 300e w124 PARTS ON EBAY!!!!!!! 6cndmbz Mercedes Used Parts For Sale & Wanted 4 09-20-2003 01:14 PM
300E idle adjust Blackbenzz Tech Help 3 11-17-2002 07:29 PM
300E High idle after revving and 10mpg royaiii Tech Help 0 10-29-2002 06:47 PM
Yet another 300E idle problem brinzbenz Tech Help 0 04-04-2002 08:07 PM



All times are GMT -4. The time now is 01:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page