Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-13-2004, 09:58 PM
Registered User
 
Join Date: Sep 2004
Posts: 3
1990sl500 starting problem

1990 SL with 36k very clean miles have an electrical problem -- intermittent
When key is turned, idiot lights go on but no click from solenoid, no turn of starter. With headlights on and key turned they do not dim.
car sits and on its own, eventually, key will work.

took into dealer and spent $360 for towing and a $50 relay replacement. Dlr said wasn't sure it would fix problem as the car started working for them before isolating fault. Home two days later won't start. 15 minutes pass and it works again.

Dlr said it could be wiring harness ($1500+) or other very expensive part and doesn't want to hunt and peck on our wallet.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page