Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-24-2000, 07:02 PM
R Opp
Posts: n/a
Car will not pick up on heat for most drives.There have been several times when ACC seemed to work. Under most circumstances it blows air at a temperature warmer than outside air, but not warm enough to heat the car. If you shut down the engine and restart in a few minutes you will get a little warm air,then back to the slightly warm air. Looks to me that something is stuck and will not pass the warm water to the heater coil. No click when you go from max to min as in my 300D. Does the 126 body use the mono valve also?? Would sure appreciate some help on this.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Running list of failures during 3 years of ownership Q ML, GL, G-Wagen, R-Class, Unimog, Sprinter 33 01-22-2006 08:13 AM
82 300SD Heating problem richclay Diesel Discussion 2 12-29-2003 06:12 PM
OVP issues and idle problem sbourg Tech Help 6 03-02-2003 09:49 AM
W202 (98 C230) A/C Problem -HELP- It's hot outside! TradeGeek Tech Help 12 07-12-2001 04:15 PM
300SDL Acceleration problem when cold. Bigrusty Tech Help 5 01-17-2000 08:49 AM

All times are GMT -4. The time now is 08:33 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page