Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-09-2005, 03:34 PM
Registered User
 
Join Date: Jun 2004
Posts: 80
SRS has me stumped

I have been working several weekends to get my SRS system working in my 86 560SL. I have replaced the control unit and the SRS Voltage Converter.

I have 12V power on both the Control Mod. and the Voltage Converter. I also have good regulated power out of the Voltage Converter. Bot Seat Belt Tensioning Retractors have the correct restisance at the Control Mod.

Could their be something wrong with the Air Bag ? How can I check to find out?

The Parts I am using are used from the salavage yard of past MBs. Is their a company that will check these parts out?

I am stumped

David
86 560SL

__________________
Dave
Reply With Quote
  #2  
Old 01-09-2005, 05:19 PM
Registered User
 
Join Date: Jan 2005
Posts: 32
Check system for codes?

The horn contact ring is suspect after 120k or so.
__________________
Todd Haven
Parts Manager
MPH Automotive
Houston,TX
Reply With Quote
  #3  
Old 01-09-2005, 05:33 PM
Registered User
 
Join Date: Jun 2004
Posts: 80
Checks Out

Thanks for the suggestion. I have good continuity with my ohm meter from the red Air bag plug to the input of the Control Mod.
Thanks again
david
86 560SL
__________________
Dave
Reply With Quote
  #4  
Old 01-09-2005, 08:41 PM
Registered User
 
Join Date: Dec 2004
Location: Findlay, Ohio
Posts: 26
After a bit of reading and looking I found the red connector shorts the pins together when you unplug the two sections. There are little fingers on the side that short the pins. I slid a short piece of plastic tubing down over each pin to hold the shorting fingers off the pins. Jerry with a 88 420 SEL.
Reply With Quote
  #5  
Old 01-09-2005, 09:01 PM
Registered User
 
Join Date: Jan 2005
Posts: 32
Dave, the airbag contact ring is 2 brass rings,and a set of brushes,
not unlike on a voltage regulator. This keeps contant contact between
steer column and air bag while wheel turns.

The brushes get worn/ring deteriorates, etc.

Tried cleaning everything surgically clean on mine, and
put new rub ring and brush set in it the next week.
__________________
Todd Haven
Parts Manager
MPH Automotive
Houston,TX
Reply With Quote
  #6  
Old 01-09-2005, 10:27 PM
Registered User
 
Join Date: Jun 2004
Posts: 80
Thanks Jerry, It took me a number of hours to find that out when I was trouble shooting. I used an old plug, to get around the shorting. Then I made my reading. Like I said I am stumped. Any other ideas?

Dave
86- 560SL

__________________
Dave
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page