Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-01-2000, 07:07 PM
Registered User
Join Date: Dec 2000
Location: SF Bay Area
Posts: 115
Hello all,

Wonderful community you have here, you all have already helped me tremendously. I've got a little problem here I was hoping for some help with.

My 1988 300E recently failed its smog test in a big way. Way over the emissions limit. The tech mentioned the ignition timing was set at 24 deg BTDC, while his book said it should be 9 degrees. Any idea what causes this?

In the interests of full disclosure, I will also mention that that I replaced the O2 sensor a few months ago, the car has days where it will not idle at all, so I'm going to check the OVP relay and fuel pump relay this weekend. I have the eha test harness on order. I admit to having turned the 3mm allen screw under the air cleaner, having very little idea of what I was actually doing. A friend told me to hook a DVM on duty cycle to pin 3 and adjust to 50%, turning the screw seemed to have very little effect, the closest I got was about 43% average, the numbers were all over the board, no consistent range.

I am committed to fixing this myself even if it costs me lots of $ in tools, I'm slowly picking up the make and model specific knowledge in this great forum. I insist on learning all this because I'm about to sell my Jeep Grand Cherokee so I can buy my wife a early '90s 300TE, which I will also have to maintain. (I am very experienced in building/repairing late '60s american hot rods.)

Thanks in advance,
Reply With Quote
Old 12-01-2000, 08:33 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Instead of using the DVOM, you can purchase a real Lambda tester for 300-400 dollars or so at Baum tools. Their site is

To pass the EMI, you will want to set it to 55% or so. I would think that the ignition timing would be OK> Since this is controlled by a computer (EZL controller), I have not seen the timing off on this engine.
Donnie Drummonds
Reply With Quote
Old 12-02-2000, 02:54 PM
Registered User
Join Date: Nov 2000
Location: Alameda, CA
Posts: 45
RE: 300E bad smog test and 24TDC

Are you experiencing any other problems with the car? Any idle issues? Power? Seems like 24tdc is indicative of other problems.
Joel P. Davis
1992 500SEL
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help 86 300E ignition problem jmyers177 Tech Help 4 01-23-2005 10:24 PM
Anybody WTB ignition wire holders (300E) mike690003 Mercedes Used Parts For Sale & Wanted 0 01-22-2005 07:29 PM
ignition timing pointer. mail2neil Tech Help 5 04-26-2004 01:32 PM
Ignition timing jundat Vintage Mercedes 1 06-21-2002 03:51 AM
300E 2.8 Timing chain Jackd Tech Help 2 02-08-2002 08:42 AM

All times are GMT -4. The time now is 08:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page