Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-18-2000, 04:49 PM
Posts: n/a
I was reading threads about problems that bad overvoltage relays can cause and I noticed that Benzmac made the comment, "I bet you jumped the battery recently." I have been having problems on my car with idling and hesitation which are symptoms of a bad OVR and my car was jumped a couple months ago. The guy who jumped me didn't do it right because he hooked the negative clamp directly to the battery which I know can cause electrical problems. Is this obviously an OVR problem or are there still other things to consider?
Reply With Quote
Old 12-18-2000, 08:27 PM
Registered User
Join Date: May 2000
Posts: 376
Check the two blade style fuses on top of the OVR. One might be blown.
Reply With Quote
Old 12-19-2000, 09:28 AM
Join Date: Aug 2000
Location: Holland, MI
Posts: 1,316
Tom, I don't know that hooking the clamp to the negative terminal causes voltage problems, but it's not recommended by the "Experts."

Clamping to the terminals WILL cause a spark when the second clamp is applied, positive or negative. This spark CAN ignite any hydrogen escaping from the battery cells through the breathers. Thus, it's better to make your first connection to the positive terminal, and the second to the frame at some safe distance, at least a few feet, from the battery.

That said, do the voltage transients from the arcing damage the OVR? If so, does it matter where you clamp, or will damage occur anyway? What is the recommended other than jumping, especially if you're stranded away from a good battery charger? Inquiring mind wants to know

BCingU, Jim
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1987 Mercedes 190e 2.3 and Overvoltage Protection Relay Eidetic57 Tech Help 3 12-13-2004 12:07 PM
Bizzarro Overvoltage relay problem classic69 Tech Help 6 10-11-2003 08:38 PM
Won't start cold-blows fuse on new overvoltage relay rradeski Tech Help 0 11-14-2001 08:51 PM
Overvoltage Protection Relay Failure Modes Telerding Tech Help 1 10-19-2001 12:17 AM
Another question about weird idle & overvoltage relay Karl226 Tech Help 4 02-20-2001 08:53 AM

All times are GMT -4. The time now is 02:44 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page