Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-31-2000, 06:39 PM
scoutindad
Guest
 
Posts: n/a
Turn signals just stopped working, no lights no clicking on our 1983 300d. Fuse is OK as brake lights and tach work. Is maybe the flasher bad, if so where is it located?
Thanks
Steve
Reply With Quote
  #2  
Old 12-31-2000, 10:20 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Just rock the switch for the hazards back and forth. They'll come back around. I have seen this a million times.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
  #3  
Old 01-01-2001, 08:32 PM
scoutindad
Guest
 
Posts: n/a
Thanks Benzmac, you were right on target!! A few toggles of the switch and they started working. Thanks again.
Reply With Quote
  #4  
Old 02-06-2001, 09:23 AM
tryingstar
Guest
 
Posts: n/a
This happened last night to me and did a search to find this thread. I also remember I accidently hit the hazard switch yesterday. Can't wait to see if this works !
Reply With Quote
  #5  
Old 02-06-2001, 03:44 PM
tryingstar
Guest
 
Posts: n/a
Eureka! Thanks Benzmac, who'd of thunk? How can the hazard switch effect the turns!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB w124 tail lights - E320, E420 style (clear turn signals) Peyton300TD Mercedes Used Parts For Sale & Wanted 1 09-21-2004 04:54 AM
hazard switch and turn signals nlz2 Tech Help 2 07-20-2004 01:42 AM
Help! Instrument panel dead, no turn signals Roger65 SL Forum 8 03-05-2004 11:48 AM
W115 Turn Signals dang50 Diesel Discussion 3 04-25-2003 07:48 PM
gauges, turn signals inoperative - any hints? wheelguru Diesel Discussion 4 03-21-2003 12:41 PM



All times are GMT -4. The time now is 05:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page