Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-29-2005, 11:05 AM
blueeagle289's Avatar
Blue Eagle
 
Join Date: Nov 2003
Location: Dallas, TX
Posts: 457
Arrow Newest Mercedes in my bunch, 420SEL

I just bought a minty 89 420SEL and the only things I can find to look at are as follows:

1. A/C is a little slow to come on after the switch is pushed; works fine after that .... has been converted to 134A

2. Security alarm is very sensitive; seems to be affected by heavy wind, etc. etc. occasionally. Can this system be adjusted to be less sensitive?

3. A slightly rough idle; higher speed performance and starting are fine? I will look at the obvious -- such as vac hoses and plug connections, but what else might cause this?

Would appreciate any thoughts on these items .... thanks, Ben Carter
__________________
Ben Harrison Carter
1999 Mercedes ML320 87K
1992 Mercedes 300CE 89K
1995 Corvette 29K -- Sold Dec 09
1989 Mercedes 420SEL 99K -- (Sold 4/08)
1968 Mercedes 230S (106K) (Sold 9/06))
1976 Mercedes 450SEL 130K (Just sold - 06)
1961 Mercedes 220Sb (sold years ago)
Reply With Quote
  #2  
Old 04-29-2005, 11:45 AM
Registered User
 
Join Date: Nov 2004
Location: Ashland, KY
Posts: 365
Number 1 - if it is on auto. it will take a second or two to come on. If not - mine does the same thing. I am not sure why. Several other friends that have the 126 chassis cars do the same thing.

Number 2 - my parent's '88 300SE has the same problem. It is in the switch in one of the doors - it is connected to the door handles. They elected to just disconnect the alarm - under passenger side floor mat.

Number 3 - could be several things. Have you checked previous maintenance records to see if the plugs, wires, rotor button, etc. have been changed? It could be the OVP (as mentioned in several other posts). It could be a vacuum leak. It might be worth taking it to a reputable independent to see what he can find for you.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1986 300SDL Question Marcb Diesel Discussion 21 02-17-2010 07:17 PM
In Today's Wall Street Journal albert champion Off-Topic Discussion 6 05-28-2004 03:10 AM
Sad day for all Mercedes Racing fans renyf1 Off-Topic Discussion 4 02-07-2003 02:45 PM
Mercedes specialty tools dmorrison General Information 10 01-29-2003 08:25 PM



All times are GMT -4. The time now is 01:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page