Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-03-2001, 01:39 PM
Registered User
Join Date: Jan 2001
Location: Boston
Posts: 42
Changed the mono-heat valve insert this morning, at your suggestion, and the heat is now consistent, thankyou. The air flow, though, continues to be stuck throwing both heat and defrost regardless of temp setting (no air ever comes through the center vents). Any suggested repair or diagnostic ideas would be appreciated. (1985 380se)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Interesting Post on AC from the Ritter/Easley Board ctaylor738 Tech Help 4 08-08-2003 06:36 PM
Plenty of heat...little heat....slow down...heat comes back Dirty Ern Diesel Discussion 15 04-02-2003 11:48 AM
injector heat shields for a 300D - are they necessary? Kent300D Diesel Discussion 13 09-19-2002 11:18 PM
New AC Servo and Amp, Still Full Heat Elripster Tech Help 2 11-27-2001 09:35 PM
85 380se heat Skorupa Tech Help 1 01-02-2001 05:55 PM

All times are GMT -4. The time now is 03:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page