Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-26-2005, 07:02 PM
Registered User
 
Join Date: Sep 2004
Posts: 49
Another Remote Keyless problem

One of my keyless remotes suddenly died on my '95 S320. No problem, just get new batteries I thought. New batteries went in and it still does not work ( or show the red indicator light when the button is pushed). Question is, is there anything inside that I can check? I tried to pry it apart to get a look-see but I was leery of breaking it even further. So before I totally destroy the thing, I thought I would consult this esteemed group.
As a last resort, is there a place that I can get just the remote unit and put my flip-out key in that unit?
Thanks
Reply With Quote
  #2  
Old 05-26-2005, 11:55 PM
Registered User
 
Join Date: Jul 2003
Location: Tulsa
Posts: 304
After you change your battery....

If the vehicle cannot be locked or unlocked it may be necessary to synchronize the lock system

1. Point remote control key at a receiver in door.
2. Press button momentarily.
3. Lock or unlock vehicle within next 30 seconds with folding key in remote control key in lock cylinder. The remote control should once again be operational.

Hope this helps!

Russell
__________________
Russell McMahon
Tulsa, OK

2001 CLK 320
1992 400se
1993 400e
2000 320ML
Reply With Quote
  #3  
Old 05-27-2005, 02:16 AM
Registered User
 
Join Date: Sep 2004
Posts: 49
Thanks for the reply Russell. I did try that as per the instructions in the owners manual without success. Unfortunately, even with the new batteries, I don't get the red light glow in the sender which indicates that the unit is working properly.
Reply With Quote
  #4  
Old 05-27-2005, 08:27 AM
Registered User
 
Join Date: Aug 2002
Posts: 179
Similar problem

I have a 95S420. The interesting thing is my remote fobs don't have any led indicators. Only the door handles light.

Non the less, when I first got the car, one of the fobs didn't work, even after replacing the batteries. With mine, in the battery holder area (uses two dime sized but thicker batteries), the contact that leads to the top most battery along the side of the case was contacting the battery below it. Effectively shorting the top battery out. Have a good look. I tried bending it back without success and ended up using paper and glue to place an insulator along the side.

By the way, seperating these things is a devil. There is a link in the forum to assist (can't remember the name though).

Ron
__________________
1995 E320 -171k-km
1995 S420 -333k-km
Reply With Quote
  #5  
Old 05-27-2005, 09:18 AM
Registered User
 
Join Date: Feb 2002
Location: east coast
Posts: 1,255
I know this sounds like poor technical advice.
After making sure the battery contacts are touching properly and the batteries aren't upside down and the remote still will not work, do nothing.
Wait a few weeks occasionally testing the unit over that time.
Hopefully the remote will magically start working again.

That is what happened with my remote.
Reply With Quote
  #6  
Old 05-27-2005, 02:18 PM
Registered User
 
Join Date: Sep 2004
Posts: 49
Thanks for the replys folks. I particularly like Ethan's idea of doing nothing and see if it fixes itself. The tinkerer in me probably won't let me do that though. I did try the insulating the contact trick to no avail. Off to do a search for opening the unit up.
Reply With Quote
  #7  
Old 05-27-2005, 02:45 PM
A. Rosich's Avatar
Registered User
 
Join Date: Nov 1999
Location: San Jose, Costa Rica
Posts: 883
[QUOTE=tower]I have a 95S420. The interesting thing is my remote fobs don't have any led indicators. Only the door handles light.



Your remote DOES have a check light, as mentioned on the first post. You have to point the sender red window to your face and press the lock buttom once. You will see a red led inside the sender window blink very fast. That is the way to check that your remote key is operating correctly and that is what S320drvr is not seeing on his key fob.

As mentioned before, it is not a bad idea to let thing stand alone a few days and let it come back to life by itself, this had happen to me too. Sometimes excessive humidity (from keeping the key at a dark and enclosed space) plays havoc with the unit. Let it stand at a well illuminated and dry place.

There is no way to obtain a sender unit from any other source than your authorized M-B dealer. The remote key controllers are factory programmed.
__________________
A. Rosich
CL 500, 1998
S 500 L, 1998
E 320 T, 1995 [Sadly sold ]
Reply With Quote
  #8  
Old 05-27-2005, 05:36 PM
Registered User
 
Join Date: Aug 2002
Posts: 179
Learn something new everyday!

Your right Mr Rosich, mine does have an led. But I have to press the button for longer than 2 seconds and it will flash once.

Cool

Thanks
__________________
1995 E320 -171k-km
1995 S420 -333k-km
Reply With Quote
  #9  
Old 05-27-2005, 09:27 PM
Registered User
 
Join Date: May 2005
Posts: 6
Quote:
Originally Posted by S320drvr
Thanks for the replys folks. I particularly like Ethan's idea of doing nothing and see if it fixes itself. The tinkerer in me probably won't let me do that though. I did try the insulating the contact trick to no avail. Off to do a search for opening the unit up.
The fact that the red light does not light up indicates to me the unit may not be getting power, recheck the battery install, and maybe the switch contacts.
Reply With Quote
  #10  
Old 05-27-2005, 09:35 PM
A. Rosich's Avatar
Registered User
 
Join Date: Nov 1999
Location: San Jose, Costa Rica
Posts: 883
One more thing: try using the batteries from the remote that works on the one you installed the new batteries.

Sometimes even new batteries can be deffective or just plain old at the retailers shelf. Or try to install the new batteries that don't work on the remote that works OK and see what happen.
__________________
A. Rosich
CL 500, 1998
S 500 L, 1998
E 320 T, 1995 [Sadly sold ]
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1992 500SL ASR Problem jrodnar Mercedes-Benz SL Discussion Forum 10 12-22-2008 12:18 PM
Help!! keyless remote jchowe420 Tech Help 4 10-20-2004 01:10 PM
Keyless Remote Dissection timz ML, GL, G-Wagen, R-Class, Unimog, Sprinter 3 09-17-2004 06:06 PM
Remote Keyless entry on 92 300SE,W140 92300SE Tech Help 1 03-15-2004 04:45 PM
W203 Keyless Remote no RF rrf Tech Help 12 06-15-2002 10:14 AM



All times are GMT -4. The time now is 10:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page