Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-30-2005, 02:32 PM
Registered User
 
Join Date: Jun 2005
Posts: 19
Question 1994 ME/BE Blower problem

Hi,
Hopefully someone can help me with a problem I'm having with the blower in my 94 E320. A few months ago I replaced the blower motor as it was defective. The new one worked fine. Now all of a sudden the blower will not work. I checked all fuses and they all checked out fine. I figured the new blower probably was defective. I got to the new blower and fed 12v directly to it and it worked fine. I checked the voltages on the red and blue leads to the blower and with ignition on, both read 12v as it should. Not being to familiar with schematics, I noticed that the blue leat comes from a Blower regulator which I'm assuming is probably the culprit, but not very sure. Can anyone tell me where exactly is the blower regulator located and is there a test that I can do that will tell me whether the problem is definately fuses, push button on/off switch, blower regulator, ground, etc. as being the most probable culprit? Or, is there a way that I can bypass everything with a switch directly to the blower to get it to work? Any advice will be greatly appreciated. Thanks. PS Does anyone know where I can purchase a Blower resister? I was told that most likely that's my problem
Bob

Last edited by bobsdynamic; 06-30-2005 at 05:49 PM.
Reply With Quote
  #2  
Old 06-30-2005, 03:21 PM
Senior Member
 
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
Blower motor reg is right under the blower motor do a search you will find lots info about a\c blower how to test it.
__________________
MB STARS Master Guild Technician,17 years MB tech
14 years independent shop owner
Reply With Quote
  #3  
Old 06-30-2005, 04:19 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
a/c fan does not go up to hi
Reply With Quote
  #4  
Old 06-30-2005, 05:47 PM
Registered User
 
Join Date: Jun 2005
Posts: 19
Blower Regulator

Quote:
Originally Posted by MB STARS
Blower motor reg is right under the blower motor do a search you will find lots info about a\c blower how to test it.
Thanks so much for the info. Bob
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
E320, 1994 Blower motor not working LETSROLL Tech Help 7 03-06-2005 11:47 AM
1994 sl w/signal light problem pep Mercedes-Benz SL Discussion Forum 9 01-27-2005 08:30 AM
140 blower motor problem, Please help? Davepnola Tech Help 8 09-13-2004 11:43 AM
W140 Blower Regulator Problem bdonkersgoed Tech Help 12 06-08-2004 03:25 PM
1994 E320 Code 6 Idle Problem 300EE320 Tech Help 29 10-14-2003 11:33 AM



All times are GMT -4. The time now is 05:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page