Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-08-2005, 04:13 AM
Skylion's Avatar
Registered User
 
Join Date: Jul 2005
Location: Sugar Land, Texas
Posts: 6
Exclamation 1998 E320 Warning Lights: ABS/ASR/BAS/ESP

Hello,

I have a 1998 E320 and a couple of months ago my Check Engine light came on. I took off the battery terminals for 10 minutes ... the light went away. But it surely came back on after 30 minutes or so.

My car has about 80,000 Miles.

A couple of weeks ago, all these warning lights came on:

1. Anti-Lock Braking System - ABS
2. ASR
3. BAS
4. ESP
5. Check Engine (has been on since my car touched 70,000 miles)

I have taken my car to a Mercedes specialist here and he told me to replace the front brake pads ... i did. AND all the lights are still on. He then suggested that the main power line in the car needs to be replaced ... which will cost me $800 !!! I dont think that is the problem though ... and even he will not guarantee that replacing the wire would surely get rid of all the warning lights.

Only thing i changed about 7 months ago was to upgrade my rims to Lorinzer rims. I have slightly bigger tires on the back. But these are 17 size original Lorinser rims !!! All the warning lights came on about 2 months ago. So i doubt the rim size or the tire size have anything to do with the warning lights either.

When the lights started turning on .... i would pull over and turn off the car for like 20 second and restart the car. All the lights would not come back (except for the check engine light). And then slowly the lights started turning on more frequently. And now the lights surely come on as soon as i put the car in Reverse or Drive ... within 5 seconds.

I had added power steering fluid ... which i purchased from Auto Zone. Maybe that has something to do with it. It was the right one ... but obviously not purchased from the dealer.

PLEASE HELP. I am so sick of these warning lights that i feel like getting rid of my car and going back to a Lexus !!!

I have not taken my car to the Mercedes dealership because i think they would charge wayyyy too much to pin point the problem and then they dont guarantee that the work they will be doing is going to correct all the problems. Any suggestions ? I mean ... how much do you think they would charge ? In Houston, Texas ?


THANKS A LOT.

Reply With Quote
  #2  
Old 07-08-2005, 05:46 AM
deltajetfixer's Avatar
Humble Benzophile
 
Join Date: Dec 2003
Location: Sharpsburg, GA
Posts: 276
Replace the $17 Brake Light Switch at the pedal...

...extremely easy repair.
__________________
2005 Pathfinder LE
2001 E55
1998 M3
1982 320i
Reply With Quote
  #3  
Old 07-08-2005, 06:22 AM
Registered User
 
Join Date: Aug 2002
Location: Southeastern PA
Posts: 3,032
Check the condition of the voltage regulator brushes.
__________________
Fred Hoelzle
Reply With Quote
  #4  
Old 07-08-2005, 09:18 AM
Registered User
 
Join Date: Nov 2002
Posts: 95
"I have slightly bigger tires on the back"

Could this be it?
Reply With Quote
  #5  
Old 07-08-2005, 09:25 AM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Quote:
Originally Posted by MarkC
"I have slightly bigger tires on the back"

Could this be it?
Of course !!!!

ASR has 4 wheel speed sensors..so, guess what. You need 4 same size tires , ASR systems will even trip codes if the air pressure is unequal...
Reply With Quote
  #6  
Old 07-08-2005, 12:27 PM
Skylion's Avatar
Registered User
 
Join Date: Jul 2005
Location: Sugar Land, Texas
Posts: 6
Quote:
Originally Posted by deltajetfixer
...extremely easy repair.
You're good

That was one of the first thing i was suggested to do. I replaced it and it didnt make any difference

Thanks though.
Reply With Quote
  #7  
Old 07-08-2005, 12:30 PM
Skylion's Avatar
Registered User
 
Join Date: Jul 2005
Location: Sugar Land, Texas
Posts: 6
Quote:
Originally Posted by Ferdman
Check the condition of the voltage regulator brushes.


How do i do that ?
I have a Pioneer AVIC-N1 Navigation System in there. And it also gives the voltage which stays at about 13.4 v


Thanks
Reply With Quote
  #8  
Old 07-08-2005, 12:34 PM
Skylion's Avatar
Registered User
 
Join Date: Jul 2005
Location: Sugar Land, Texas
Posts: 6
Quote:
Originally Posted by MarkC
"I have slightly bigger tires on the back"

Could this be it?

A couple of guys have told me that ... but the thing is that i replaced the rims and tires almost 8 months ago. And all this started about 2 months back. So if the problem was the rims or tires .... should the warning lights have come on after i installed them ?

You think it can be some sensors ?
Because the warning lights come on ... one after the other ... as soon as i start driving it. Like within 5 seconds !!!

Thanks for all your help guys.
Reply With Quote
  #9  
Old 07-08-2005, 01:20 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Why don't you just go get the codes instead of having us mention things it could be..??????
Reply With Quote
  #10  
Old 07-08-2005, 01:28 PM
yal's Avatar
yal yal is offline
Benz-smart
 
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,706
Yeah stop at autozone or something and get the OBDII codes read.
Reply With Quote
  #11  
Old 07-09-2005, 02:51 AM
Skylion's Avatar
Registered User
 
Join Date: Jul 2005
Location: Sugar Land, Texas
Posts: 6
Angry

Quote:
Originally Posted by Arthur Dalton
Why don't you just go get the codes instead of having us mention things it could be..??????


Wow .... Mr. Genius
Thanks for all your help.

If i knew how and where to get the codes ... i wouldn't be here writing all this stuff !!!

Thanks YAL ... i will take my car to Auto Zone first thing tomorrow.
Reply With Quote
  #12  
Old 07-09-2005, 10:37 AM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
[QUOTE=Skylion]Wow .... Mr. Genius
Thanks for all your help.

If i knew how and where to get the codes ... i wouldn't be here writing all this stuff !!!


That post was intended to help you get to the problem in short order and was the best info you have recieved so far .Pal... when you see the code list and the long list of possible remedies , you will value that opinion.
Along with my other post informing you of the problems of mis-sizing tires with 4 wheel speed sensor/ASR data interchange..

Have a nice day..
Reply With Quote
  #13  
Old 06-27-2006, 08:22 PM
Skylion's Avatar
Registered User
 
Join Date: Jul 2005
Location: Sugar Land, Texas
Posts: 6
Tadaaaaaaaaaa

It's the ASR/ABS unit guys !!!

On my 1998 E320 ... the part Number is: A 003 431 30 12






Reply With Quote
  #14  
Old 08-15-2006, 04:19 PM
Registered User
 
Join Date: Jan 2001
Location: Western NJ
Posts: 173
ASR/BAS Fix

Skylion,
Congrats on fixing the problem you had with your 1998 E320. What was the approx cost of the fix ?
Thanks,
Ken
__________________
2014 E250 Bluetec 4-Matic
2014 GL350 Bluetec 4-Matic
1996 Chevy Tahoe 4 x 4
2009 ML350 (sold)
2005 SLK350 (sold)
1999 E300 Turbodiesel (sold)
1998 ML320 (sold)
1991 300D 2.5 Turbodiesel (sold)
Reply With Quote
  #15  
Old 08-15-2006, 06:44 PM
david s poole
 
Join Date: Mar 2005
Location: dallas
Posts: 1,822
1998 e320

dont care what the codes say.there are 4 electrical connections in the brake light switch and only 2 control the brake lites.the other two control all the lights you are staring at .you need a brake lite switch as you were told earlier and make sure you buy it from a dealer as the aftermarket ones are junk. after you do this simple repair start the car and turn the wheels lock to lock and all your lites will be out. david poole dallas tx.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 E320 w/ only 1 Electronic KEY - Need Another mossimmo Tech Help 3 11-30-2004 07:15 PM
dim glow on warning light panel lights Jerry Burtman Tech Help 2 12-23-2002 07:26 PM
car died at light, ALL warning lights came on, no start david74mr Tech Help 10 12-11-2002 08:42 AM
dash warning lights stay on HELP!!!! W124 chazmo Tech Help 0 10-06-2002 02:08 PM
Mysterious Lamp Defect Warning light on 97 W210 E320 ken320 Tech Help 1 08-09-2001 09:25 AM



All times are GMT -4. The time now is 10:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page