Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-23-2001, 01:19 PM
Posts: n/a
My 1987 560SEL has an intermittent problem, the oxygen sensor light flickers on and off, the engine hesitates and sometimes stalls while this is happening. The oxygen sensor has been replaced, and this did nothing for the problem. Also the AIR pump cycles on and off when the light flickers. Any help would be appreciated.
Reply With Quote
Old 01-23-2001, 07:30 PM
Posts: n/a
Who replaced the O2 sensor? Also, make sure all connections are in place. The sensors come with anti-seize compound on the threads, but if some gets on the sensor. It makes the sensor useless. Get it checked out.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
560 sel hesitation demeterial Tech Help 7 10-21-2004 11:41 PM
90 560 SEL Rough Idle & Hesitation Rich126 Tech Help 0 10-04-2004 11:28 PM
560 sel hesitation demeterial Tech Help 1 06-16-2004 10:12 PM
1991 560 sel hesitation demeterial Tech Help 0 02-27-2004 10:15 PM
1983 300SD or 1987 560 SEL BenzFreak Diesel Discussion 2 05-19-2003 01:05 AM

All times are GMT -4. The time now is 05:41 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page