Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-15-2005, 10:06 PM
Registered User
 
Join Date: Aug 2005
Posts: 4
shuts down

Our 1986 190 2.3 8valve shuts off after it reaches operating temperature. I have replaced the Ignition Module and the fuel filter. Still shuts off, I can run the fan with heat on high to go a little further but when it hits 80 degs it just turns off. After a few minutes I can drive again. Pleace. any sugestions. steve

Reply With Quote
  #2  
Old 08-17-2005, 01:12 AM
Brooklyn,NY
 
Join Date: Apr 2005
Location: Brooklyn,NY
Posts: 252
might be engine temperature sensor? might short or create open circuit once normal temperature is reached.
__________________
1999 ML430 Silver 135k ml
Smoked LED taillights, Alpine in-dash DVD player, 12" sub, Pioneer components, 2 amps, 4200k HIDs, ML55 headlights, 20" rims, mirror LED blinkers

SOLD. 1996 E320 145k ml. Burgundy

SOLD but miss it everyday 1992 500sel Black
Chime buzzer mod,Alpine CD/MP3 player with stock amp,Euro headlights,S600 grill,20" rims, BEST CAR EVER!

SOLD. 1990 300E White
187k ml,smoked tails,Euro headlights,17rims,Intake,12" sub in first aid kit,alarm/autostart,buzzer mod

Reply With Quote
  #3  
Old 08-17-2005, 03:23 AM
Registered User
 
Join Date: Dec 2003
Location: Fribourg, Switzerland
Posts: 277
Hi
For quite a few people such symptons have been caused by a faulty crankshaft postion sensor.
Good luck, Bruno
__________________
_
1992 300TE 160 kmiles
Reply With Quote
  #4  
Old 08-17-2005, 11:39 AM
Registered User
 
Join Date: Jul 2001
Location: SoCal
Posts: 1,303
When engine is warm, it goes into loop control monitoring lambda via the O2 sensor. I would check this sensor, since a really bad reading from this would cause the ECU to command the EHA to send the mixture outside operating parameters. Bad output from the ECU to the EHA valve might also be a cause.

Steve
__________________
'91 MB 190E 2.3
'08 RAV4 Ltd 3.5
'83 Lazy Daze m'home 5.7
Reply With Quote
  #5  
Old 08-18-2005, 09:04 PM
Registered User
 
Join Date: Aug 2005
Posts: 4
Quote:
Originally Posted by Victor300E
might be engine temperature sensor? might short or create open circuit once normal temperature is reached.
thank you very much, I'll give it a try. steve
Reply With Quote
  #6  
Old 08-18-2005, 09:54 PM
Registered User
 
Join Date: May 2004
Location: New Zealand
Posts: 160
just cuts right out? does it restart easily?

OVP and Fuel pump relay have both been culprits for this in my experience.

Although the fuel pump relay will ussually not restart for a while.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
190E 2.6 shuts off when it gets hot darsyl32 Tech Help 7 02-15-2005 06:28 AM
190E Shuts off benzito190 Tech Help 3 08-24-2004 05:56 PM
300D A/C comes on at start then shuts off JamesStein Diesel Discussion 1 05-23-2004 12:41 AM
My engine shuts off ONLY if I open the Drivers Door! 240 Ed Diesel Discussion 5 04-22-2002 11:27 PM
High beams on, car shuts off! Excellent! ShadeTreeSteve Vintage Mercedes Forum 4 10-09-2001 11:26 PM



All times are GMT -4. The time now is 12:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page