Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-17-2005, 12:35 AM
Rookie DIYer
 
Join Date: Jun 2002
Posts: 106
A/C Out Makes a Noise - Engine Stutters

I JUST had my water pump replaced and all was well until today...

I have a 1996 C280. Recently if I have the A/C on when I start the car and attempt to drive the car stutters a little and you have to start giving it some gas to get it to stop, it stops after running a while.

Today the A/C vents made a funny noise, like the opening and closing noise when you first turn it on. Sort of makes a hissing sound.

This isn't present when on defrost or heat, only when programmed for cold air. The air is no longer cold and the sound persists.

Could this be a condenser issue? Freon? or is it something else, maybe a fan or belt out of vacum leak?

I am not very knowledgable when it comes to cooling systems so any help will be greatly appreciated. Its hard to drive a car with no A/C in 100 degree Dallas heat.

__________________

2004 CLK500
2000 S500
Reply With Quote
  #2  
Old 08-17-2005, 02:35 AM
moddin' da 124
 
Join Date: Aug 2005
Location: hk
Posts: 5
i have exactly the same problem. exactly. just started too...
Reply With Quote
  #3  
Old 08-17-2005, 12:54 PM
Rookie DIYer
 
Join Date: Jun 2002
Posts: 106
re

wow, have you figured out what it was or taken it to a shop yet?
__________________

2004 CLK500
2000 S500
Reply With Quote
  #4  
Old 08-17-2005, 06:47 PM
Rookie DIYer
 
Join Date: Jun 2002
Posts: 106
re

turns out it was low on freon. just took it today $60 to fill it up and suck all the air and moisture out of the system. Well worth it b/c now its colder than ever.
__________________

2004 CLK500
2000 S500
Reply With Quote
  #5  
Old 08-18-2005, 01:45 AM
moddin' da 124
 
Join Date: Aug 2005
Location: hk
Posts: 5
i filled mine up too, a few days ago, hissing noise went away only temporarily though, now it makes a funny noise everytime i step on the gas. i know this was posted somewhere here a while ago, i think, but cant seem to find it... how is your idle now? mine seems to be fine...
Reply With Quote
  #6  
Old 08-21-2005, 05:06 PM
Rookie DIYer
 
Join Date: Jun 2002
Posts: 106
re:

i think i have a leak. i filled it up but the AC is dead again. doing some more investigating this week. let me know if you figure anything out.

__________________

2004 CLK500
2000 S500
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Noise 1991 300E bschroer Tech Help 7 02-05-2005 02:04 AM
Engine noise at startup jeansain Tech Help 6 11-28-2004 05:25 PM
a/c makes hissing noise, doesnt blow cold Grdenko Tech Help 3 11-14-2003 02:31 PM
rattling noise from engine JHZR2 Diesel Discussion 7 09-21-2002 12:16 PM
2000 CLK320 Engine and A/C query barflux Tech Help 30 09-09-2002 06:11 PM



All times are GMT -4. The time now is 08:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page