Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-29-2001, 03:07 PM
Posts: n/a
I am having some problems with my 1991 420 SEL.

Previously, it had a high idle, approximately 1,400 RPMs when warm. The dealer found some bad wiring around the EZL unit, after the wiring was repaired the idle now appears "normal" and is about 800-900 RPMs when warm.

Here the new problem: when traveling down the road, and I start to slowly back off of the throttle, I reach a point where if feels as if the engine abruptly seems to die - like I let off of the gas really fast even though I didn't (it doesn't actually die, but if sure feels like it). I am assuming that this is an abrupt transition to "idle". When I ease on the throttle again, I can feel it transition hard again as if the engine is now back on. I hope I am explaining this clearly. It doesn't do this every time I let off of the throttle (sometimes it is very smooth even though I let off fast), and it doesn't do it that I can notice with the car in park or neutral, only traveling down the road.

Acceleration is good, and I notice no other symptoms other than the hard transition from letting off of the throttle and applying throttle? The idle is not erratic, although it does seem to vary a little between 800 and 900 RPMs.

Could this be the air slide valve sticking or not functioning properly; if so can this be cleaned or does it need to be replaced? Additionally, I found some info regarding the overflow voltage protection relay (OVP), could my problem be associated with this as well?

Any help or suggestions would certainly be appreciated.

1991 420 SEL
Reply With Quote
Old 01-29-2001, 09:17 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I would have the idle switch checked to make sure the adjustment is proper. Also, I have seen the airflow meter do the same thing.
Donnie Drummonds
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent idle problem, 86 300SDL Jim H Diesel Discussion 5 10-23-2004 12:54 PM
m104 1994 e320 throttle mcdill Tech Help 15 06-28-2004 11:26 PM
240D shakey at idle, fast idle, how to adjust?? unkl300d Diesel Discussion 4 10-19-2003 08:39 PM
86 560SEL cold start/rough idle algae1 Tech Help 8 07-16-2002 07:49 AM
Idle out of control dpetryk Tech Help 3 10-05-2001 07:02 PM

All times are GMT -4. The time now is 03:19 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page