Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-25-2005, 06:06 PM
Registered User
 
Join Date: Oct 2005
Location: MA
Posts: 22
Thumbs up 97 C230 code P0170 in 01 & 02

Hi!
I had this code come on now for a while, oc2 was change and code P1070 in 01 & 02 keep coming up, usually after the car has run for quite a while. I saw on the tech post references to the air flow censor, and my guest was of the egr valve or the thermal switch to the valve, is this correct and can you tell me exactly what it may be and the fix?

Thank you

Reply With Quote
  #2  
Old 10-25-2005, 09:01 PM
Registered User
 
Join Date: Feb 2002
Location: east coast
Posts: 1,255
use the SEARCH engine on this forum, type in P1070 and you'll get; instructions and where to buy plus additional diagnosti info.
Reply With Quote
  #3  
Old 10-26-2005, 01:11 PM
Registered User
 
Join Date: Oct 2005
Location: MA
Posts: 22
P0170

Thanks Ethan

Seems that it's the same thing that I just fixed on a Grand Marqui, just needed some cleaning of air intake. I would hate to replace the air flow meter unless I have to
Thank again
Reply With Quote
  #4  
Old 10-26-2005, 02:54 PM
Registered User
 
Join Date: Feb 2002
Location: east coast
Posts: 1,255
I had the same code and Check Engine light go off on my 1998 C-230, the big thing for me was the funny way the transmission was acting.
I didn't read or check adaptation values and gambled on the MAS sensor, which in deed did fix my problem.

I always thought intake cleaning or repairng of the MAF/MAS sensor wouldn't work, but I did read on one forum ( maybe here or at www.club202.com) someone posted directions on how to attempt a repair on the MAF/MAS.
Reply With Quote
  #5  
Old 10-27-2005, 02:37 PM
Registered User
 
Join Date: Oct 2005
Location: MA
Posts: 22
Cool p0170

So far so good my light hasn't come on for afew days after puting the oc2 censor. No isues with the trainy so far! By the way no free speech at (www.club202.com)
Reply With Quote
  #6  
Old 10-27-2005, 03:41 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
What is an oc2 ??
Reply With Quote
  #7  
Old 10-28-2005, 02:45 PM
Registered User
 
Join Date: Oct 2005
Location: MA
Posts: 22
Cool co2 sensor

sorry my mispelling, I meant the Lambda sensor or the oxygen sensor (O2).
Light came back on today,I just clean and cleared code ,will see if that helps.
By the way sl 600 cruzin posted on 4/28/05 on low fuel pressure and the fuel filter , that was my original diagnos, got a fuel filter last week ,still have to install it.

That's better! 02

Last edited by goodboytony; 10-28-2005 at 05:24 PM.
Reply With Quote
  #8  
Old 10-28-2005, 03:06 PM
Registered User
 
Join Date: Feb 2003
Location: Ontario, Canada
Posts: 3,160
Quote:
Originally Posted by goodboytony
I meant the Lambda sensor or the oxygen sensor (CO2).
Oxygen = O2
__________________
2007 C 230 Sport.
Reply With Quote
  #9  
Old 10-28-2005, 05:21 PM
Registered User
 
Join Date: Oct 2005
Location: MA
Posts: 22
Thumbs up 02

Thank you I stand corrected, and I installed the fuel filter ,I'll let you know if it does the job (p0170)
Reply With Quote
  #10  
Old 10-28-2005, 07:20 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Your code means the system is at its max adjustment and can no longer adapt to an air/fuel imbalance..
This can be caused by a lean condition, in which case the vac lines shoud all be checked for possible leaks [ on that chassis , check around the front of the engine, the line that go to the switch-over valves for EGR]

Also can be caused by a rich condition . In that case , a possible is the fuel regulator has a ruptured diaphragm . This can be checked by taking the hose off the reg. and looking for fuel in the hose.. there should be none.
A fuel pressure test is in order to complete this test.
And then , there is the possibility that the MAF is not reporting the correct intake air mass , in which case it is faulty [ a good possibity].. but , the proper sequence is start with the vav leak/fuel pressure first.
Adapatation specs are used for this diagnosis, but that requires equipment , so for the diyer , do the above sequence .
You may just have a bad fuel feed, so you will know with the new filter....
" 02 Sensor "is the proper terminology..
Reply With Quote
  #11  
Old 10-31-2005, 01:24 PM
Registered User
 
Join Date: Oct 2005
Location: MA
Posts: 22
Smile 02 sensor

The intallation of the fuel filter has done the job in conbination with cleaning of air sensor , used electrical contact cleaner, will be back when next problem comes up, and thank you all that help in resolving my issue with this p0170 code, for now i will work on my spelling!
Reply With Quote
  #12  
Old 10-31-2005, 02:05 PM
Registered User
 
Join Date: Feb 2003
Location: Ontario, Canada
Posts: 3,160
Talking

Quote:
Originally Posted by goodboytony
for now i will work on my spelling!
Go to your room & write:
Oxygen Sensor = O2 sensor.
100 times !
__________________
2007 C 230 Sport.
Reply With Quote
  #13  
Old 10-31-2005, 03:11 PM
Registered User
 
Join Date: Oct 2005
Location: MA
Posts: 22
Cool 97 c230 p1070

Man!!
Spoke to soon!
Fifth & six grade used to make me do that untill I dicided not to do the lines!
The teacher didn't know what to do anymore, another kid had a nervous break down in class and that was it for lines.
now code p0170-02 & p0133 -01
Reply With Quote
  #14  
Old 11-01-2005, 01:08 AM
blackmercedes's Avatar
Just a guy
 
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
Stop throwing parts at it and have the adaptation codes read.
__________________
John Shellenberg
1998 C230 "Black Betty" 240K

http://img31.exs.cx/img31/4050/tophat6.gif
Reply With Quote
  #15  
Old 11-01-2005, 01:24 PM
Registered User
 
Join Date: Oct 2005
Location: MA
Posts: 22
Cool 97 C230 code P0170 in 01

Hi! John Shellenberg
Adaptation codes? I use an Obd II code,I guess I should have the mech. look at it. My car idles correctly as far as I can tell, my last try is going to be the second 02
The car did adapt and now no code, the fuel filter must of been the culpit.
sensor.
1997 c230 120,340 miles


Last edited by goodboytony; 11-01-2005 at 04:44 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page