Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-16-2005, 12:10 AM
MLSL
Guest
 
Posts: n/a
secondary air injection system trouble

I have a 98 SL500. Ocasionally the check engine light comes on. I have a code reader and the error mesage is "secondary air injection system malfunction". I can reset it and it will be fine for a while. Have not noticed any pattern of when it comes on, maybe at idle when humidity is high. I've heard this can be very expensive and hard to solve. Anyone know of a good system check to isolate problem.

Reply With Quote
  #2  
Old 11-16-2005, 08:23 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Exclamation

MANY scanners have the ability to activate that emission system(and most other systems as well). You need to do that in order to diagnose the problem.

When the air pump runs the FRONT O2 sensors must react to the oxygen from the pump & stop cycling. They MUST stay at 50mv or less durning that test!
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 11-19-2005, 11:51 PM
Registered User
 
Join Date: Nov 2005
Location: NW usa
Posts: 34
check out this thread
http://www.peachparts.com/shopforum/tech-help/135607-w-124-air-pump-failing.html#post1019089
Reply With Quote
  #4  
Old 11-20-2005, 05:42 AM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Quote:
Originally Posted by rwogs

That thread is for the old belt drive pumps.

Your chassis has an electric pump

http://catalog.eautopartscatalog.com/mercedesshop/sophio/image.jsp?title=Air%20Pump&url=http%3A//img.eautopartscatalog.com/live/B601070965BOS.JPG
Check if it comes on and check fuse power.
Reply With Quote
  #5  
Old 11-20-2005, 09:39 AM
Johnhef's Avatar
Senior Member
 
Join Date: Feb 2005
Location: Frederick, Md
Posts: 4,540
if the air pump works
possibly clogged/not opening air valves or egr ports in the head. I just fought an E320 with the same problem. It would turn the light on after 100 miles or so.

pay close attention to the o2 voltages
__________________


1980 500SE/AMG Euro
1981 500SEL Euro
1982 380SEL
1983 300TD
1983 500SEC/AMG Euro
1984 500SEC
1984 300TD Euro
1986 190E 2.3-16
1986 190E 2.3
1987 300D
1997 C36 AMG
2003 C320T 4matic

past: 1969 280SE 4.5 | 1978 240D | 1978 300D | 1981 300SD | 1981 300SD | 1982 300CD | 1983 300CD | 1983 300SD | 1983 380SEC | 1984 300D | 1984 300D | 1984 300TD | 1984 500SEL | 1984 300SD | 1985 300D | 1986 300E | 1986 560SEL | 1986 560SEL/Carat | 1987 560SEC | 1991 300D 2.5 | 2006 R350
Reply With Quote
  #6  
Old 11-20-2005, 10:08 AM
Registered User
 
Join Date: Sep 2003
Location: Dallas, Tx
Posts: 701
One thing to check is the vacuum line from the switch to the bypass valve. I had that occur on my SL and that is what it turned out to be. Check out our website at www.mbca.org/northtexas, go to tech stuff, then engine technical, there is location of engine controls. Fully inspect the vacuum lines to the bypass valve, the switch, and even check the valve to see if it is operating. Get this fixed as if it is broken you could ruin your air pump, or even worse ruin the converters. Good luck!
Brian

__________________
Brian W. Heitman

www.MBCA.org/northtexas

Join MBCA!!!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page