Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-16-2005, 10:20 PM
Registered User
 
Join Date: Oct 2002
Posts: 178
Quick question about P/S fluid

car is a '90 190E.

I got a qt of M-B P/S fluid ($$$!). Can I add that in to my P/S resevoir with unknown fluid inside? I don't know if ATF is in there. Is M-B fluid okay for older models? Also, just to make sure, to access the resevoir, I unscrew the black knob and lift up the lid? Thanks.

Reply With Quote
  #2  
Old 11-16-2005, 10:25 PM
dudley
 
Join Date: Nov 2005
Location: kansas city Missouri
Posts: 16
Question New to MB and have question on 1992 190e

I found this website and was hoping some one could help. I just purchased my first MB. Its a 1992 190e 2.3 with 90,000 miles. The heater is working but the two center vents are blowing cold air. I assume that they stuck on vent. Any suggestions?
Reply With Quote
  #3  
Old 11-16-2005, 10:33 PM
dudley
 
Join Date: Nov 2005
Location: kansas city Missouri
Posts: 16
sorry

sorry Frosty. I was trying to post a new thread. Sorry I dont know anything about ps fluid.
Reply With Quote
  #4  
Old 11-17-2005, 01:04 AM
Registered User
 
Join Date: Oct 2002
Posts: 178
That's okay, dudly. Your 190E heating is working just fine. My '90 190E does the same thing. The center vents do not blow hot air, just the side vents. You have to close them the center vents if you just want hot air. I was told by the salesperson that all M-B do that, or at least the older models. I think the 300E does too. Yeah, I thought something was wrong with the heater when I was testing all the functions. It's normal. Maybe someone can confirm this?

Btw, I hope you enjoy your 190E. It's one of my favorite M-B models.
Reply With Quote
  #5  
Old 11-17-2005, 02:18 AM
Registered User
 
Join Date: Jun 2001
Location: Canada
Posts: 219
On the 300E / E320, the centre vents will indeed blow some warm air, but only 'intermittently' or 'periodically', 'depending on the interior temperature' -- that's what the manual says.

On my E320, I'm certain warm air blows from the centre vents, just not really sure how intermittent it really is.
Reply With Quote
  #6  
Old 11-17-2005, 02:29 AM
Registered User
 
Join Date: May 1999
Location: Sacramento, CA
Posts: 1,490
Yeah, just unscrew the black knob and the cap should lift off. You can probably add regular P/S fluid in there, it should be fine. If you want, you can try blotting some old fluid onto a white paper towel, if it's ATF you should get a red tint even if the fluid is really dirty. Regular P/S fluid is clear.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page