Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-18-2005, 08:49 PM
3 MB's and counting!
 
Join Date: Apr 2001
Location: Toronto, Canada
Posts: 1,825
MAS cooked after rustproofing done?

Well last weekend I decided to get my 99 W202 C230K rustproofed for the first time since it never seen the snow and it will now.

A few days later the Check engine came on...car acting the same and just had the codes read today....shows MAS airflow sensor.

My mechanic was guessing the spray from the rustproof got sucked into the intake and now ruined the MAS sensor.

Im going to get a new one tommorow but mostlikely this is true u think?

__________________
99 C43
98 S420
99 C230K
01 C240
Reply With Quote
  #2  
Old 11-18-2005, 10:22 PM
Hatterasguy's Avatar
Zero
 
Join Date: Nov 2002
Location: Milford, CT
Posts: 19,306
Well the only problem with that logic is the air filter is in the way. Not to mention why would the car be running as they were spraying it.
__________________
2020 GMC Sierra Denali
2007 Tiara 3200
Reply With Quote
  #3  
Old 11-18-2005, 10:23 PM
Registered User
 
Join Date: Oct 2004
Posts: 3,546
Doesn't sound very likely. The air filter should have stopped anything harmful. MAF sensors go bad all the time. If it contained silicone and was injested by the engine then it is likely that the O2 sensors could be damaged too. When replacing the MAF you should also replace the o-ring in the filter housing as well as the air filter.
Reply With Quote
  #4  
Old 11-19-2005, 01:08 AM
3 MB's and counting!
 
Join Date: Apr 2001
Location: Toronto, Canada
Posts: 1,825
Code was checked and reset and never came back on after a few hours drive. Car tends to "bog down" slightly when accelerating harder such as getting on the highway and thats about it.....shifts normally etc.

Ya and car was not running when rustproofing was being done but I recall oil mist flying everywhere in the shop and they did spray in the engine bay areas...the intake on the other side where the air goes in is oily but I will take a better look tommorow.

__________________
99 C43
98 S420
99 C230K
01 C240
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page