Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-19-2005, 07:48 PM
Registered User
 
Join Date: Jul 2004
Location: NC
Posts: 1,140
MBDOC may have been right about my "lemon" (AMM or Trans?)

So the motor has been running rough the past few days. Today, under load, the trans didnt want to downshift, and when it did, it was surging, backing off, then surging again to accelerate. IT feels peppy in town and when RPMs are low, but if you call for anything over 3k of acceleration, strange things happen. I have no CEL. Could this be the AMM?

__________________
former: 83 300D, 97 C230, 93 400E

current: 08 C300 Luxury , 92 500SL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page