Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-19-2005, 09:29 PM
Registered User
 
Join Date: May 2004
Posts: 108
C220 fault code

I have a 1995 c220 with a "100-CAN no signal from the dm" code in the computer. I am using an AST retriever from the 38 pin diagnostic plug. My best guess looking over the wring diagram is the OBD2 Diagnostic Module has a problem. My mitchel wiring diagram says the module is in the center rear of the engine comp. I have looked all over the engine compartment withut any luck. Does anyone know where this module is located?
Looking over the wiring diagram I cannot find any obvious power to the module. It could be comming from the Engine control module on a green/red or yellow/red wire. I hope to check there for power in when I can find the module. Any help will be apreciated. Thanks John

Reply With Quote
  #2  
Old 11-19-2005, 09:31 PM
carson356
Guest
 
Posts: n/a
Quote:
Originally Posted by bergmjh
I have a 1995 c220 with a "100-CAN no signal from the dm" code in the computer. I am using an AST retriever from the 38 pin diagnostic plug. My best guess looking over the wring diagram is the OBD2 Diagnostic Module has a problem. My mitchel wiring diagram says the module is in the center rear of the engine comp. I have looked all over the engine compartment withot any luck. Does anyone know where this module is located?
Looking over the wiring diagram I cannot find any obvious power to the module. It could be comming from the Engine control module on a green/red or yellow/red wire. I hope to check there for power in when I can find the module. Any help will be apreciated. Thanks John
i believe it is under the dash on ther drivers side close tho the light switch, but under neath, i will see if i can find out for certain, i will let you know, btw those modules are quite costly. if you are able to communicate with it chances are it has power, the can part of it has probably failed, i have seen a few do that.
Reply With Quote
  #3  
Old 11-19-2005, 09:43 PM
Registered User
 
Join Date: May 2004
Posts: 108
Thanks I will look under the drivers side kick pannel. I also looked in the dm part of my retrievers live data capabilities and it said the dm had no inputs or something to that extent. I will keep you posted. John
Reply With Quote
  #4  
Old 11-19-2005, 09:44 PM
carson356
Guest
 
Posts: n/a
ok here is a picture i found, from the looks of it on your model it is under the passenger side foot rest area under the panel below the carpet.[/

Reply With Quote
  #5  
Old 01-17-2006, 05:01 PM
Registered User
 
Join Date: May 2004
Posts: 108
The computer seems to be fine. I disconnected the computer and then reconected it and the problem went away. The car has run fine for about 3 months now. Thanks for the location of the computer. John

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page