Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-20-2005, 12:27 PM
Registered User
 
Join Date: Oct 2004
Posts: 185
Where is relay- NEED HELP NOW!!!

1987 560sel stalls, but will start and run then stops.
checked volts at pump and it has a loss of power to pump when stalls.
Getting 13 volts at fuel pump when it does start up. OVP?? where is that located also?
Where is the fuel pump relay too??
I guess it may be a relay??

Where is it located??

Any suggestions??

Thanks
John1

Last edited by John1; 11-20-2005 at 01:07 PM.
Reply With Quote
  #2  
Old 11-20-2005, 04:52 PM
jdc1244's Avatar
Read Only
 
Join Date: Apr 2003
Location: Lakeland, FL
Posts: 170
The fuel pump relay should be located in the same place for your 87, behind the glove box:

1986 560 Sl Fuel Pump Relay location

The OVP is located in the middle of the two firewalls, it has a red top Ė you canít miss it.
Reply With Quote
  #3  
Old 11-20-2005, 06:09 PM
Registered User
 
Join Date: Oct 2004
Posts: 185
jdc

JDC

Thanks so very much!

John1
Reply With Quote
  #4  
Old 11-21-2005, 10:29 AM
Registered User
 
Join Date: Oct 2005
Location: wisconsin
Posts: 21
no power to fuel pump relay

You seemed very helpfull on 1987 560. Can you help me on a 1973 450se euro? This is a 116 body I do not have power to the fuel pump relay, I can not locate the main fuel relay, the pump relay is in the fuse box left inner fender, I have tried to trace the red wire from battery to the main relay however I lose the wire when it enters the firewall.
any help is appreciated.
Reply With Quote
  #5  
Old 11-21-2005, 06:58 PM
jdc1244's Avatar
Read Only
 
Join Date: Apr 2003
Location: Lakeland, FL
Posts: 170
Sorry, I donít know the 116s, just the 126s. might want to post a thread for your problem.

Do you know if the fuel pump is getting power? If the relay for the 116 is the same you can jump the relay and make a connection between the battery and the pump to see if the pump is good. In a 126 (and 124 and 201, I believe) if the pump comes on you know the relay is bad. Sometimes the relay can be resoldered or worse case replaced. If you can jump your pump from the battery through the relay and it works, then the relay needs to be replaced and it would otherwise have power.

Good luck.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page