Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-21-2005, 10:35 PM
Akuma
 
Join Date: Nov 2005
Location: Georgia
Posts: 4
Speed Sensor

I have a 1991 300SL (5 Speed standard). My speedometer doesn't work. I took it to a shop that repairs speedometers, and they told me that they couldn't find anything wrong with it. They thought it may be an electrical problem. I took my car to an electrician and they didn't find any problem. They suggested that the speed sensor was bad. I ordered the sensor and took it to a Mercedes Dealer. No one there knew how to put the sensor in. They called around to other dealers and they didn't know either. They also looked it up in the computer and there wasn't anything there on how and how long it would take. They offered me to give them a open check to fix it, which they said would take maybe 5-10 hours. I decided not to go that way, but I'm still where I started at. I was told that there weren't but a few of these cars were made and not too many people have worked on them. I need help!!! IS THERE ANYONE THAT CAN SUGGEST A REPAIR SHOP, IN THE ATLANTA AREA, THAT CAN WORK ON THIS CAR AND FIX THIS PROBLEM???


Last edited by mshadesan; 11-23-2005 at 10:20 PM.
Reply With Quote
  #2  
Old 11-22-2005, 04:35 AM
zcc's Avatar
zcc zcc is offline
Registered User
 
Join Date: Nov 2005
Location: Kuwait
Posts: 610
I guess that the spees senson is a wire connects from the speedometer to the transmission. But I suspects that the speedometer itself is infected. All the best. : ))..
__________________
Master Computer Engineer, A+, Network+, MCP/MCSA/MCSE 4/2k/2k3 - Messaging, MCTS, MCITP, MCT, Brainbench, ICDL and starting Ph.D

380SE 1984 <------- Totaled by flipping accident
300SE 1988 <------- Sold
Volvo S70 2000 <---- 4 family
Opel Omega 2002 <-- 4 family
560SEC 1989 <------ Sold
560SEL 1990 <------ Sold
560SEL 1991 <------ 4 my mother
560SEL 1989 <------ Sold
600SEL 1992 <------ Current


http://search.ebay.com/_W0QQsassZkhazenzcc
Reply With Quote
  #3  
Old 12-10-2005, 02:37 AM
Akuma
 
Join Date: Nov 2005
Location: Georgia
Posts: 4
Thumbs up Got It Fixed!!!!

Quote:
Originally Posted by mshadesan
I have a 1991 300SL (5 Speed standard). My speedometer doesn't work. I took it to a shop that repairs speedometers, and they told me that they couldn't find anything wrong with it. They thought it may be an electrical problem. I took my car to an electrician and they didn't find any problem. They suggested that the speed sensor was bad. I ordered the sensor and took it to a Mercedes Dealer. No one there knew how to put the sensor in. They called around to other dealers and they didn't know either. They also looked it up in the computer and there wasn't anything there on how and how long it would take. They offered me to give them a open check to fix it, which they said would take maybe 5-10 hours. I decided not to go that way, but I'm still where I started at. I was told that there weren't but a few of these cars were made and not too many people have worked on them. I need help!!! IS THERE ANYONE THAT CAN SUGGEST A REPAIR SHOP, IN THE ATLANTA AREA, THAT CAN WORK ON THIS CAR AND FIX THIS PROBLEM???
I finnally got it fixed!! And it was the speed sensor. As I was trying to get my car repaired I found out that in 1991 they imported only a few of these models with a 5 speed manual. I found a mechanic in Decatur, Ga. that repair it for me. I think that the other people that I contacted before didn't won't to work on it because they hadn't worked on this model and year with a 5 speed manual.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page