Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-22-2005, 08:36 AM
Registered User
 
Join Date: Nov 2005
Posts: 1
Troubled

I have a 1997 E-420, with 98,322 miles, the car is in excellent shape and was running fine until yesterday. I'm new at this so please bare with me. The day before yeaterday I'm cleaning my car, inside and out to include the engine compartment. I sprayed the engine off while the car was running, and also drove the car a few miles to dry the engine off. The following day I'm driving my car to work and notice a significant change in the idleing in the car. While driving it, the whole car shakes when I accelerate and idles very ruff when I'm at a complete stop. Last night I inspected all of my vacum hoses and found no problems. Is it possible that I damaged something electrical or something minor i'm over looking? Any comments would be helpful.

Thank you,

Robert of Miami

Reply With Quote
  #2  
Old 11-23-2005, 04:42 PM
Registered User
 
Join Date: Jul 2000
Posts: 638
why is my 'wet' engine missing?

Check for water in the distributor cap--frequently happens from an old/missing seal. When the car gets hot, it vaporizes, condenses on the cap , shorts out, causing bad misfires etc..
Reply With Quote
  #3  
Old 11-23-2005, 05:48 PM
ace ace is offline
Registered User
 
Join Date: Nov 2005
Posts: 33
I had the same thing happen once after an engine wash. Actually got a "check engine electronics" message along with it. A bunch of water had ended up in the cavities around the spark plugs. If you have a compressor I recommend blowing it out with that. The previous person responding to your post said something about a distributor. If your 97 E410 is the same as mine then it has a coil for each spark plug, I don't think that there is a distributor.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page