Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-25-2005, 12:16 PM
sfloriII's Avatar
Still pedaling...
 
Join Date: Aug 2003
Location: Northern VA
Posts: 1,614
Gremlin in my E-320 finally diagnosed

Hey Guys,

Thanks for the advise about the ticking noise and fluctuating idle problems in my E-320 you've been giving me over the last few months.

I talked to my mechanic and told him I was taking my car to the dealership, since he couldn't figure out the problem without me throwing various expensive (like a new wiring harness!!) parts at it.

The dealership discovered that the cruise control/idle control thingy was bad. They simply threw parts at my car until the problem dissapeared.

The part new from the dealer is about $1400! I found one from Potomac German in MD for a bit over $300 and my mechanic will install it for free since I've had this problem for so long.

Anyone interested in a good wiring harness for around $200? I still have the old one that was replaced without needing it.

__________________

Current:
2014 VW Tiguan SEL 4Motion 43,000 miles.

2016 Hyundai Santa Fe Sport (wife's).

Past:
2006 Jetta TDI 135,970 miles. Sold Nov. '13.
1995 E-320 Special Edition. 220,200 miles. Sold Sept. '07.
1987 190-E 16 valve. 153,000 miles. Sold Feb. '06.
1980 300-D 225,000 miles. Donated to the National Kidney Foundation.
1980 240-D manual, 297,500 miles. Totaled by inattentive driver.
Reply With Quote
  #2  
Old 11-25-2005, 01:44 PM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 12,569
Was it the idle control valve that went bad Stefano? If I am not mistaken the records you got with the car indicated that the harness had been replaced. You may be able to sell it on ebay. Glad to hear you got it sorted out.
__________________
Jim
Reply With Quote
  #3  
Old 11-25-2005, 05:30 PM
Moderator
 
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,538
I think he's talking about the throttle actuator, aka EA / ISC / CC, Electronic Accelerator, Idle Speed Control, Cruise Control.

All three functions are combined in one part. If one function fails, then the whole part needs to be replaced.
__________________
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote
  #4  
Old 11-26-2005, 02:52 AM
sfloriII's Avatar
Still pedaling...
 
Join Date: Aug 2003
Location: Northern VA
Posts: 1,614
It turned out to be the cruise control/idle speed control unit.

Part number: 1245455532.

My mechanic had told me he thought it was the wiring harness, which I bought independently and had him inistall it. 'Course that wasn't the problem! I'll try to sell the old one on ebay.

The mechanic at the dealership that diagnosed the actual problem said that the unit (brains?) looked as though it had been fried. They'd never seen that happen before.
__________________

Current:
2014 VW Tiguan SEL 4Motion 43,000 miles.

2016 Hyundai Santa Fe Sport (wife's).

Past:
2006 Jetta TDI 135,970 miles. Sold Nov. '13.
1995 E-320 Special Edition. 220,200 miles. Sold Sept. '07.
1987 190-E 16 valve. 153,000 miles. Sold Feb. '06.
1980 300-D 225,000 miles. Donated to the National Kidney Foundation.
1980 240-D manual, 297,500 miles. Totaled by inattentive driver.
Reply With Quote
  #5  
Old 11-26-2005, 10:37 AM
JimF's Avatar
'94 S500: only 793 sold!
 
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,933
Glad it fixed and I'm sure you are too!

A fried ECU is usually the by-product of a wiring harness failure.
__________________
Regards . . . . JimF
-------------------
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
  #6  
Old 11-26-2005, 12:02 PM
. . . . . . .
 
Join Date: May 1999
Location: Omaha, Nebraska
Posts: 177
If the replaced wiring harness on your 1995 with 190,000+ miles was the original, your mechanic did you a favor by having it replaced. It would be only a matter of time before it caused other serious issues. If it was the original wiring harness, you would be doing your fellow Benz owners a disservice by trying to sell it.
Reply With Quote
  #7  
Old 11-26-2005, 12:41 PM
sfloriII's Avatar
Still pedaling...
 
Join Date: Aug 2003
Location: Northern VA
Posts: 1,614
Quote:
Originally Posted by Bob I
If the replaced wiring harness on your 1995 with 190,000+ miles was the original, your mechanic did you a favor by having it replaced. It would be only a matter of time before it caused other serious issues. If it was the original wiring harness, you would be doing your fellow Benz owners a disservice by trying to sell it.
The original wiring harness was replaced, so this one was not the orginal. As it is, if I were to sell it and it turned out to be bad, I'd gladly refund the money.
__________________

Current:
2014 VW Tiguan SEL 4Motion 43,000 miles.

2016 Hyundai Santa Fe Sport (wife's).

Past:
2006 Jetta TDI 135,970 miles. Sold Nov. '13.
1995 E-320 Special Edition. 220,200 miles. Sold Sept. '07.
1987 190-E 16 valve. 153,000 miles. Sold Feb. '06.
1980 300-D 225,000 miles. Donated to the National Kidney Foundation.
1980 240-D manual, 297,500 miles. Totaled by inattentive driver.
Reply With Quote
  #8  
Old 11-26-2005, 12:42 PM
sfloriII's Avatar
Still pedaling...
 
Join Date: Aug 2003
Location: Northern VA
Posts: 1,614
Quote:
Originally Posted by JimF
Glad it fixed and I'm sure you are too!

A fried ECU is usually the by-product of a wiring harness failure.
That's what my mechanic said too, but I figured maybe he was just trying to make me feel less bad about having it replaced!

__________________

Current:
2014 VW Tiguan SEL 4Motion 43,000 miles.

2016 Hyundai Santa Fe Sport (wife's).

Past:
2006 Jetta TDI 135,970 miles. Sold Nov. '13.
1995 E-320 Special Edition. 220,200 miles. Sold Sept. '07.
1987 190-E 16 valve. 153,000 miles. Sold Feb. '06.
1980 300-D 225,000 miles. Donated to the National Kidney Foundation.
1980 240-D manual, 297,500 miles. Totaled by inattentive driver.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page