Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-03-2006, 07:09 PM
fhmajid
Guest
 
Posts: n/a
500E Transmission Problem? Rebuild?

Hi,

I have a 110k mile 500E in beautiful condition. Transmission seems to hesitate mildly (slipping) when shifting. Also, trans wont shift into reverse without increasing engine revs to 1,500 rpm at which point the engagement is rather abrupt.

I suspect a rebuild is in order. Any ideas on prognosis, minimal cost and repair shops in the greater Philly area?

Thanks
farrukh
Reply With Quote
  #2  
Old 01-03-2006, 07:36 PM
Holeshot's Avatar
Have gunsight will travel
 
Join Date: Jan 2004
Location: (near) Seattle, WA
Posts: 258
My 500E with about 132,000 is not shifting 'perfectly' and I'm considering a re-fresh just for piece of mind. So I'm also interested in details on any 500 specific rebuild issues. I had that trans in my 300E does some years back and it was about $2200 to drop it off, overhaul and pick it up. Not *too* bad.. hardly free though!
__________________
-----------------------------------------------------
David - Bremerton, WA
1999 CLK430 - daily driver
1995 993 C2 - race modified (auto-x weapon)
2000 Durango - parts and dirt bike hauler
2005 KTM950S - Baja, here I come!!!
Bloggy blogger blog
Reply With Quote
  #3  
Old 01-03-2006, 09:32 PM
C32AMG's Avatar
Registered User
 
Join Date: Mar 2004
Location: new york/orange county
Posts: 639
A delay into reverse in early high mileage cars with 722.3, 4 and 5 transmission is a common problem, clutch Flaking , excessive clearance is the cause Did you check the fluid level, if full, I would remove the pan and filter, check for clutch and band debris in the filter and pan. If itís clean, change the filter and fluid, adjusting the modulator two turns CW may solve the slipping problem.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page