Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 01-23-2006, 12:57 AM
420 SE's Avatar
Whats next?
 
Join Date: Sep 2005
Location: Coolum Beach, QLD, AUS
Posts: 284
Dollars to peanuts that blown fuse will be why the windows don't work!!!

You still have a lot of leaves in your engine bay

__________________
1988 W126 420 SE

beware of fundamentalists!
Reply With Quote
  #17  
Old 01-23-2006, 01:08 AM
86560SEL's Avatar
Registered User
 
Join Date: Jan 2003
Location: east Tennessee (southeast USA)
Posts: 3,015
Yep - I am hoping that when I install a new and proper amp fuse, that they will work again. Hopefully there is not anything wrong with them.

Yeah, I need to clean out more leaves. I actually did not even do the passenger side. Guess I will do that soon.


Quote:
Originally Posted by 420 SE
Dollars to peanuts that blown fuse will be why the windows don't work!!!

You still have a lot of leaves in your engine bay

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page