Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-18-2006, 03:11 PM
Registered User
 
Join Date: Nov 2005
Posts: 55
slightly "rough" idle on C280

I have a 1999 C280 (V6) which idles slightly rough. Its not a constant rough idle. It will idle smoothly for say about 5 sec and then it will shake slightly- idle smooth, then shake. The rev counter only moves slightly, maybe 100 RPM, if than much - but it definately does have movement.

I already replaced the MAF sensor, due to stalling problems. The Benz technicians also say the car does not give any fault codes. They suggest either new plugs, or engine mounts. I don't really have confidence in their abilities and dont want to replace something if it wont cure the problem (already done to much of that)

Any suggestions??

I do have some question for the guru's:

1) Can it be motor mounts if the rev needle moves slightly during the "rough" idling?
2) If the problem is spark plug related, shouldn't it give an error code?

Something else: it does not make a difference whether the transmission is in P,N or D.

Thanks for helping

Reply With Quote
  #2  
Old 01-18-2006, 03:33 PM
forp's Avatar
Registered User
 
Join Date: Jul 2003
Location: Sebastopol, CA
Posts: 324
How many miles on the car? Are the original spark plugs still in it?
Dan
__________________
2012 E350 Bluetech
Reply With Quote
  #3  
Old 01-18-2006, 03:49 PM
Registered User
 
Join Date: Nov 2005
Posts: 55
It has about 150 000 km and the plugs were changed at 90 000 km.
Reply With Quote
  #4  
Old 01-19-2006, 01:20 AM
Registered User
 
Join Date: Jul 2004
Posts: 139
Does your model have coil packs? My 1997 C280 (I6) has a coil pack for each two cylinders and I have had to replace two already, the second just last week. (87,000mi.) When mine went out there was occasional backfiring and sluggish acceleration along with the check engine light going on. Simple to replace and with discounts cost approx. $90.00 each at the dealer.

Tim
Reply With Quote
  #5  
Old 01-19-2006, 11:00 AM
Registered User
 
Join Date: Nov 2005
Posts: 55
Well I don't know the first thing about engines, but I supose it will have coil packs.

As I said, the idling is not really rough - will rather call it uneven. And I dont get any CEL lights or error codes.

Anyone care to comment on my two questions in my first post. This problem is really irritating me. Especially because the Benz mechanics don't know for sure what the problem is, and want to solve it by throwing parts at it.
Reply With Quote
  #6  
Old 01-24-2006, 11:07 AM
Registered User
 
Join Date: Nov 2005
Posts: 55
Will really appreciate it if someone can comment on the questions in my original post.

I've since realised that the roughness is not only on idle. It also misses if I increase the revs slightly to 2000. Aslo, when I really push the car, it has a hick-up / misses (only for a instant) at about 5000 RPMs - mostly only in 3rd gear.
Reply With Quote
  #7  
Old 01-25-2006, 01:09 AM
Registered User
 
Join Date: Nov 2005
Posts: 55
nobody?
Reply With Quote
  #8  
Old 01-25-2006, 06:12 AM
Registered User
 
Join Date: Nov 2002
Posts: 95
Quote:
Originally Posted by leonb
I have a 1999 C280 (V6) which idles slightly rough. Its not a constant rough idle. It will idle smoothly for say about 5 sec and then it will shake slightly- idle smooth, then shake. .............
Sounds like the AC engaging on and off with the auto climate control. Did you try setting it on economy mode? Mine also did this when the water pump started to go bad (seizing bearings), but this was accompanied by a squealing belt. I have a 98C280, same V6 engine.
MarkC
Reply With Quote
  #9  
Old 01-25-2006, 11:18 AM
Registered User
 
Join Date: Nov 2005
Posts: 55
Thanks for the advise Mark. I checked, the roughness remains whether the A/C is on or off. Also no squealing or grinding noises.

Any other suggestions?

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page