Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-19-2006, 05:02 PM
Registered User
 
Join Date: Feb 2005
Posts: 68
Question Electrical Problem--Please Help

1991 300ce

I turned the lights on the other night, and the two headlights and one passenger side tailight came on. Neither the driver side tailight nor the instrument cluster nor the switches lit up. Backseat reading light comes on, door lights work, trunk light works, license plate lights work. I checked the fuse 3 which controls this and it is fine. Im lost here. Does anyone know what this can be?

thanks
a.b.

Reply With Quote
  #2  
Old 01-20-2006, 12:15 AM
86560SEL's Avatar
Registered User
 
Join Date: Jan 2003
Location: east Tennessee (southeast USA)
Posts: 3,015
Possibly the old "faulty wiring harness" issue? Did it affect the 91's?

Does this affect the lighting systems?

I am sure someone will have more info on this.
Reply With Quote
  #3  
Old 01-20-2006, 09:34 AM
MrCjames's Avatar
California Dreaming
 
Join Date: Jun 2003
Location: SF Bay Area
Posts: 599
Quote:
Originally Posted by e320 coupe
1991 300ce

Neither the driver side tailight nor the instrument cluster nor the switches lit up.

thanks
a.b.
Perhaps it is 2 seperate issues that just happen to occur at the same time. I would think the little red fuse on the back of your instrument cluster might answer the interior illumination issue. As far as the tail light goes, perform a visual check to ensure the the harness was not inadvertanlty disconnected.

If there is a connection between the 2 failures the only immediate thought I have is the headlamp switch. I'll check the electrical manual and follow up on it later today.
Reply With Quote
  #4  
Old 01-20-2006, 11:40 AM
Senior Member
 
Join Date: Jun 2001
Location: Northern Calif. (Fairfield Area)
Posts: 2,225
When you start the car and turn on the lights, does the little lamp failure light on the instrument clstr come on?
__________________
Auto Zentral Ltd.
Reply With Quote
  #5  
Old 01-20-2006, 01:13 PM
Registered User
 
Join Date: Feb 2005
Posts: 68
No, the 'lights out' dummy light does not come on. (And, I didnt know that there is a fuse behind the instrument cluster)
Reply With Quote
  #6  
Old 01-20-2006, 01:37 PM
MrCjames's Avatar
California Dreaming
 
Join Date: Jun 2003
Location: SF Bay Area
Posts: 599
Quote:
Originally Posted by e320 coupe
No, the 'lights out' dummy light does not come on. (And, I didnt know that there is a fuse behind the instrument cluster)
A little red one, looks similar to one of the dash bulbs only it is red. It is for the interior illumination, and without looking at the diagram I want to say for the dash lights. I do need to check so bear with me

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page