Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-05-2001, 04:58 PM
Registered User
Join Date: May 1999
Location: New Location: VA Palo Alto HEALTH CARE SERVICES
Posts: 109
Does anyone had experienced having the car alarm goes on while driving on the road..? This 88 420 SEL has given me this situation and I have to pull over to de-activate it. However, ..the alarm goes on and on again. I did check all doors, making sure that they are all locked up but it did'nt correct the problem. Would you please advice me on what else to check. I won't be able to use this car again until I found the problem. Thanks....
Reply With Quote
Old 03-05-2001, 05:50 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
One of the door handle micro-switches are sending an arm signal to alarm computer w/driving. Somewhat common. Will require a new switch(handle) to fix. Or the alarm ECU(computer) is defective.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 03-05-2001, 08:35 PM
Registered User
Join Date: May 1999
Location: New Location: VA Palo Alto HEALTH CARE SERVICES
Posts: 109
Car Alarm


Thanks a lot for your prompt reply, ..we'll take your advice for action. In the meantime, ..could it be possible to dis-able this system temporarily so that I can use the car ? Please advice how.....?
Reply With Quote
Old 03-05-2001, 09:27 PM
Registered User
Join Date: Dec 2000
Location: Mt. Airy, Maryland
Posts: 116

I am not familiar with the MB alarms. I had the same problem on my Camry and I disconnected the ground wire on the siren (alarm).

Hope this helps.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Car alarms - is the SL factory alarm enough? KenSilver SL Forum 14 04-05-2004 01:13 AM
Stuff that makes you wonder. Post your pictures!! Cap'n Carageous Open Discussion 88 11-01-2003 03:15 PM
Thoughts on built-in alarm Jassper Diesel Discussion 15 07-26-2003 06:08 PM
Time for a car pshibly Open Discussion 3 12-31-2002 11:14 AM
E500/500E with over 100K miles rpm8100 Performance Paddock 9 12-30-2002 03:46 PM

All times are GMT -4. The time now is 05:33 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page