Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-08-2001, 11:04 PM
Larry R
 
Join Date: Feb 2001
Location: Oklahoma
Posts: 20
I am having a problem with my automatic transmission. It has a delayed shift from 2nd to 3rd and then it goes into 4th prematurely. Do I have a major problem. I have kept the fluids changed. It has 100K on it.

Thanks Larry
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
87 300e clicking from valves? and tranny problem dirtysocks Tech Help 1 05-26-2004 02:08 AM
1984 Mercedes 190E, three questions, please help! rbort Tech Help 3 02-23-2004 03:29 PM
1987 190E 2.6 tranny problem pmount Tech Help 4 02-10-2003 02:26 AM
190e 2.6 auxilliary water pump problem. Darin Darlingto Tech Help 4 03-28-2002 09:22 PM
Tranny problem elau Tech Help 0 02-27-2002 12:24 PM



All times are GMT -4. The time now is 06:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page