Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-09-2001, 05:53 PM
Posts: n/a
Hi guys
the problem was a bend intake valve!
Probably I did something wrong before mounting the head and turned the cams separately so that one valve bended the other…and needed to be replaced!
Now that is resolved, the engine runs, but to fast (1500 rpm)
I tried everything but cannot get a lower idle, what to do?
Any suggestions?

Reply With Quote
Old 03-09-2001, 06:58 PM
Michael's Avatar
Join Date: Jul 1999
Location: CT, USA
Posts: 2,699
What year/model/engine?

Please specify year/model/engine when posting mechanical questions...otherwise, guys like Doc, Benzmac, Steve and Aaron will not know which of the approximately 4.2 trillion answers in their heads is correct.

Just kidding with ya, but please do advise.
"If everything seems under control, you're simply not going fast enough" --Mario Andretti

1995 E500 street car
1986 Porsche 944 Turbo S track car
Reply With Quote
Old 03-10-2001, 12:35 AM
Registered User
Join Date: Feb 2001
Location: SE PA
Posts: 63

Post as a reply to your original post to bring it to the top of the list. This refreshes us with the original description of the problem. Hopefully, you also gave more identication info originally as well!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Schrick M103 Camshaft with Valve Springs AMGmercedes Mercedes Used Parts For Sale & Wanted 1 02-20-2004 08:32 AM
300D valve tolerances sperry Diesel Discussion 2 12-02-2003 11:58 AM
valve stem seals mer280sel Vintage Mercedes 6 10-10-2003 09:17 PM
Idle control valve broken?? W126 finn Tech Help 7 08-10-2003 03:40 PM
M103 Valve guides edbardzik Tech Help 3 06-01-2000 07:37 AM

All times are GMT -4. The time now is 04:39 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page