Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-09-2001, 10:56 PM
Larry R
Join Date: Feb 2001
Location: Oklahoma
Posts: 20
I am having a problem with my automatic transmission. It has a delayed shift from 2nd to 3rd and then it goes into 4th prematurely. Do I have a major problem. I have kept the fluids changed. It has 100K on it.

Thanks Larry

1984 190E 100K
1974 240D Sold
1968 250S Sold
Reply With Quote
Old 03-10-2001, 12:00 PM
Join Date: Aug 2000
Location: Holland, MI
Posts: 1,316
It could just be a few adjustments need to be made. Try searching on "transmissions" and "shifting" throught the forums.

Also, a quick visit to a trained MB technician, dealer or independent would put you way ahead!

BCingU, Jim
Reply With Quote
Old 03-10-2001, 09:31 PM
Registered User
Join Date: Jan 2001
Location: Tucson, Arizona
Posts: 758
Similar Problem Larry

Greetings Larry,

I seem to be having the same problem with the '80 300TD I feel the shift from 1st to 2nd, but the 2nd to 3rd gear is either instantly happening right after that, engine feels sluggish at that point, then the 4th gear kicks in about 30-40 MPH. It has me stumped and I have posted it that way. Perhaps if I don't get a tech to respond to my question I will drain the fluid and torque converter and replace the filter to see if that makes the difference.

Any input from the pro's would be great to lead us along an educated guess.

Reply With Quote
Old 03-14-2001, 11:13 PM
Registered User
Join Date: Feb 2001
Location: Atlanta
Posts: 63
Hey gang,

I found some interesting tranny articles at
Don't know if they will apply to your probs. The site's links are screwy so try different paths. I think most people that end up at mercedesshop have been to the other site first but they are a good resource as they have a "tips" section with step by step instructions.


[Edited by mcamara on 03-14-2001 at 11:17 PM]
Matt Camara
'83 300SD
'85 Celica
'98 Harley Springer Softail
Reply With Quote
Old 03-15-2001, 08:16 PM
Registered User
Join Date: Jan 2001
Location: Tucson, Arizona
Posts: 758
To Save Time Click on The Link Below

Greetings All,

Not to say that I don't like surfing the net, but if you are wanting info quick, click on the link below to take you to the where you can read fixes and suggestions for your particular model as the post above suggests. It doesn't contain it all, but if you don't get anything else out of it, some humor has been added. Does not equal the site that we have here, but there are some useful tricks to doing things.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Icky 300D Auto Transmission Problem Richard Eldridge Diesel Discussion 0 05-18-2004 01:53 PM
1981 380SE Transmission Problem mapab Tech Help 1 05-14-2004 07:49 AM
Help? Advice? 300E transmission prob... KNanthrup Tech Help 9 09-18-2003 08:09 PM
Manual transmission problem !!!!!! Bige Tech Help 2 11-23-2002 05:27 PM
Help, transmission problem 300-CE Rako Tech Help 5 11-11-2002 09:22 AM

All times are GMT -4. The time now is 09:16 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page